• Mobile apps - просто как 2х2!

    Рост количества информации и ускорение темпов жизни все сильнее требует постоянного присутсвия в рабочей сети, в том числе и в пути. Именно поэтому такю большую популярность приобретают смартфоны, КПК и планшеты, представляющие собой мобильные компьютеры для доступа к рабочей и личной информации.

    Сегодня довольно сложно встретить человека без мобильного телефона или смартфона. Это уже не просто средство связи, но также и инструмент для работы, управления личными данными, общения в интернете, а также разного вида развлечений.

     
     
  • Аналитические данные

    Для иллюстрации разнообразных аналитических и научных данных довольно удобно использовать красивые диаграммы. Табличный редактор  от Microsoft Excel 2010 предлагает огромное количество как стандартных так и довольно редких диаграмм и позволяет создавать сложные комбинации из уже существующих шаблонов.

    Создать диаграмму в программе Excel 2010 довольно просто, так как, открывая эту программу, вам потребуется нажать всголишь пару кнопок. Остается всего лишь их заполнить таблицу с данными. Как же это сделать?Вы узнаете из статей нашего сайта.

     
  •  E-mail и рассылки

    Не секрет, что на сегодняшний день E-mail рассылка всё еще является эффективным рекламным средством, признанным во всей интернет среде, по соотношению цена качество. Охват массовой рассылки соизмерим, разве, что с рекламой по телефону

    Маркетинг путем рассылок по электронной почте позволяет создать необходимую программу регулярных рассылок для продвижения своего бренла и развития бизнеса в целом. Наконец, правильно построенный интернет маркетинг по почте может укрепить положительные взаимоотношения клиентов и организации.

     
  • Мобильные устройства

    Новости, обзоры и тесты портативной техники и мобильных устройств. Современные смартфоны, КПК и планшеты содержат в себе довольно взрослый функционал, аналогичный такому же у своих «старших братьев». Удаленное администрирование, браузеры с технологиями flash и java-script, синхронизация электронной почты, заметок, обмен различными файлами. Обо всем этом и не только подробнее на нашем сайте.

8.x Код для формирования проводок для Акциза

Категория Помощь

Написать код для формирования проводок для Акциза... кипит мозг нихрена не понимаю... в семерке он выглядел так:ЕстьАкциз = глЕстьРеквизитМнЧ("Акциз", Док.Вид()); Если ЕстьАкциз = 1 Тогда Док.ВыбратьСтроки(); Пока Док.ПолучитьСтроку() = 1 Цикл Если Док.ВидМПЗ = Перечисление.ВидыМПЗ.Материалы Тогда СуммаАкциза=Док.Акциз; Если Док.ДатаДок Написать код для формирования проводок для Акциза... кипит мозг нихрена не понимаю... в семерке он выглядел так:




ЕстьАкциз = глЕстьРеквизитМнЧ("Акциз", Док.Вид());
Если ЕстьАкциз = 1 Тогда
Док.ВыбратьСтроки();
Пока Док.ПолучитьСтроку() = 1 Цикл

Если Док.ВидМПЗ = Перечисление.ВидыМПЗ.Материалы Тогда
СуммаАкциза=Док.Акциз;
Если Док.ДатаДок<Дата("31.12.2005") Тогда
Если Док.НеЗачетАкциза = 0 Тогда
глПроводка(СчетПоКоду("68.3"), Перечисление.ВидыПлатежейВБюджет.Налог, , ,СчетПоКоду("19.5"), Док.Контрагент, Док.Договор, , СуммаАкциза, "Зачет Акциза");
Иначе
глПроводка(СчетПоКоду("20"), Константа.Субконто1_20, Константа.Субконто2_20,Константа.Субконто3_20 ,СчетПоКоду("19.5"), Док.Контрагент, Док.Договор, , СуммаАкциза, "Акциз не зачитываемый");
КонецЕсли;
Иначе
глПроводка(СчетПоКоду("19.5"), Док.Контрагент, Док.Договор, , СчетПоКоду("60.1"), Док.Контрагент, Док.Договор, , СуммаАкциза, "Акциз");
Если Док.НеЗачетАкциза = 1 Тогда
глПроводка(СчетПоКоду("20"), Константа.Субконто1_20, Константа.Субконто2_20,Константа.Субконто3_20 ,СчетПоКоду("19.5"), Док.Контрагент, Док.Договор, , СуммаАкциза, "Акциз не зачитываемый");
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЦикла;
КонецЕсли;


в восьмерке не могу сообразить... надо сеня к вечеру!! срочно!!

Комментарии  

 
0 #4 dmitrij 30.07.2013 23:19
Если номенклатура разделяется на материалы и товары по другому признаку, можешь не использовать регистр сведений
 
 
0 #3 dmitrij 30.07.2013 21:52
Запрос примерно так будет выглядеть:
"ВЫБРАТЬ
| СУММА(Поступлен иеТоваровУслугТ овары.Акциз) КАК Акциз,
| ПоступлениеТоваровУслугТовары.НеЗачетАкциза
|ИЗ
| Документ.Поступ лениеТоваровУсл уг.Товары КАК ПоступлениеТоваровУслугТовары
| ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений .СчетаУчетаНоме нклатуры КАК СчетаУчетаНоменклатуры
| ПО ПоступлениеТова ровУслугТовары. Номенклатура = СчетаУчетаНоменклатуры.Номенклатура
| И ПоступлениеТова ровУслугТовары. Ссылка.Организа ция = СчетаУчетаНоменклатуры.Организация
|ГДЕ
| ПоступлениеТова ровУслугТовары. Ссылка = &Ссылка
| И СчетаУчетаНомен клатуры.СчетУче таБУ В ИЕРАРХИИ(&СчетМатериалов)
|
|СГРУППИРОВАТЬ ПО
| ПоступлениеТова ровУслугТовары. НеЗачетАкциза"
 
 
0 #2 kira 30.07.2013 21:47
короче всегда если есть акциз проводки с 60 на 19.5, если не зачет акциза (в форме флажок) с 19,5 на 20.. типа так


Бухгалтерия, документ "поступление товаров и услуг", форма дополнена колонкой акциз и флажком "не зачет акциза"

Процедура в модуле объекта ДвиженияПоРегис трам
 
 
0 #1 dmitrij 30.07.2013 21:47
А в чем проблема то: как запрос построить или как проводки в движения добавить? Задавай конкретные вопросы, а то так неспортивно :)
 

You have no rights to post comments