• Mobile apps - просто как 2х2!

    Рост количества информации и ускорение темпов жизни все сильнее требует постоянного присутсвия в рабочей сети, в том числе и в пути. Именно поэтому такю большую популярность приобретают смартфоны, КПК и планшеты, представляющие собой мобильные компьютеры для доступа к рабочей и личной информации.

    Сегодня довольно сложно встретить человека без мобильного телефона или смартфона. Это уже не просто средство связи, но также и инструмент для работы, управления личными данными, общения в интернете, а также разного вида развлечений.

     
     
  • Аналитические данные

    Для иллюстрации разнообразных аналитических и научных данных довольно удобно использовать красивые диаграммы. Табличный редактор  от Microsoft Excel 2010 предлагает огромное количество как стандартных так и довольно редких диаграмм и позволяет создавать сложные комбинации из уже существующих шаблонов.

    Создать диаграмму в программе Excel 2010 довольно просто, так как, открывая эту программу, вам потребуется нажать всголишь пару кнопок. Остается всего лишь их заполнить таблицу с данными. Как же это сделать?Вы узнаете из статей нашего сайта.

     
  •  E-mail и рассылки

    Не секрет, что на сегодняшний день E-mail рассылка всё еще является эффективным рекламным средством, признанным во всей интернет среде, по соотношению цена качество. Охват массовой рассылки соизмерим, разве, что с рекламой по телефону

    Маркетинг путем рассылок по электронной почте позволяет создать необходимую программу регулярных рассылок для продвижения своего бренла и развития бизнеса в целом. Наконец, правильно построенный интернет маркетинг по почте может укрепить положительные взаимоотношения клиентов и организации.

     
  • Мобильные устройства

    Новости, обзоры и тесты портативной техники и мобильных устройств. Современные смартфоны, КПК и планшеты содержат в себе довольно взрослый функционал, аналогичный такому же у своих «старших братьев». Удаленное администрирование, браузеры с технологиями flash и java-script, синхронизация электронной почты, заметок, обмен различными файлами. Обо всем этом и не только подробнее на нашем сайте.

вывод числа прописью

Категория Помощь

как вывести в скд прописью результат? во вкладке макеты-параметры макета создаю параметр, что писать в поле "выражение"? пишу ЧислоПрописью() выдаёт синтаксическую ошибку, платформа 8.2 как вывести в скд прописью результат? во вкладке макеты-параметры макета создаю параметр, что писать в поле "выражение"? пишу ЧислоПрописью() выдаёт синтаксическую ошибку, платформа 8.2

Комментарии  

 
0 #11 nadin 15.08.2013 19:56
Цитирую olja:
Вот текст всей процедуры, работает:Результат= Сумма;ЦелаяЧасть = Цел(Сумма);ФорматСтрока = "Л=ru_RU; ДП=Ложь";Если ТипЗнч(Валюта) = Тип("СправочникСсылка.Валюты") Тогда ПарамПредмета = Валюта.ПараметрыПрописиНаРусском;Иначе ПарамПредмета = "рубль, ру[censored], рублей, м, копейка, копейки, копеек, ж, 2";КонецЕсли; Если Результат = ЦелаяЧасть Тогда Если ВыводитьСуммуБезКопеек Тогда Результат = ЧислоПрописью(Результат, ФорматСтрока, ПарамПредмета); Результат = Лев(Результат, Найти(Результат, "0") - 1); Иначе Результат = ЧислоПрописью(Результат, ФорматСтрока, ПарамПредмета); КонецЕсли;Иначе Результат = ЧислоПрописью(Результат, ФорматСтрока, ПарамПредмета);КонецЕсли;Возврат Результат;Делала на платформе 8.2


Спасибо большое! То, что нужно!
 
 
0 #10 urij 30.07.2013 00:10
Андрей, ну почему же, информацию можно и тут получить, просто там народу больше, как следствие - быстрее.

Оля, ну я же не хамил. На счет Вашей компетентности не слова не сказал. Советов не просил. Цену себе знаю, цену сертификатов тоже знаю (сертификат не показатель знаний), у самого их пачка где-то валяется... Если бы я ничего про СКД не знал, я бы молчал в тряпочку и ничего писать бы не стал, но я работаю с СКД с момента её появления и в этой области имею колоссальный опыт. Со мной на эту тему спорить бесполезно. Думаю, вопрос исчерпан.
 
 
0 #9 dmitriy 22.07.2013 08:27
ИМХО:
Сертификаты, и другие «регалии» могут помочь, но не гарантируют результата, как и их отсутствие.
 
 
0 #8 andrej 04.07.2013 10:18
спасибо за совет! считаешь, что смысла нет находиться в таких группах в контакте?
 
 
0 #7 urij 29.06.2013 07:14
"а СКД предпочитаю не пользоваться, ... она замедляет работу" - бредятина полная...
СКД намного увеличивает скорость работы, для тех, кто уже научился ей пользоваться. А если не умеешь, то какая тебе разница, где кнопку сформировать нажать - в отчете с СКД или в обычном отчете? Никак это не замедлит твою работу...

Андрей, читай правильные форумы, вроде Мисты, тут бесполезно спрашивать...
Вот, перейди по ссылке: [censored]://[c ensored].forum. mista.ru , нажми "Поиск", набери "V8 СКД число прописью". Там полно тем по этому вопросу...
 
 
0 #6 andrej 28.06.2013 10:46
спасибо за подробное описание, вот только мне нужно в скд всё это дело оформить, на языке запросов я это сделал и там легко выводится сумма прописью.
может, эту процедуру сделать как функцию и выводить из неё переменную? а эту полученную переменную(проп исью написанную) вставлять в скд, можно ли так, интересно?
 
 
0 #5 olja 24.06.2013 00:01
Вот текст всей процедуры, работает:

Результат= Сумма;
ЦелаяЧасть = Цел(Сумма);
ФорматСтрока = "Л=ru_RU; ДП=Ложь";
Если ТипЗнч(Валюта) = Тип("Справочник Ссылка.Валюты") Тогда
ПарамПредмета = Валюта.ПараметрыПрописиНаРусском;
Иначе
ПарамПредмета = "рубль, ру[censored], рублей, м, копейка, копейки, копеек, ж, 2";
КонецЕсли;

Если Результат = ЦелаяЧасть Тогда
Если ВыводитьСуммуБе зКопеек Тогда
Результат = ЧислоПрописью(Р езультат, ФорматСтрока, ПарамПредмета);
Результат = Лев(Результат, Найти(Результат , "0") - 1);
Иначе
Результат = ЧислоПрописью(Р езультат, ФорматСтрока, ПарамПредмета);
КонецЕсли;
Иначе
Результат = ЧислоПрописью(Р езультат, ФорматСтрока, ПарамПредмета);
КонецЕсли;

Возврат Результат;

Делала на платформе 8.2
 
 
0 #4 andrej 10.06.2013 20:12
а там по СКД сделано?
можете скрин сделать?
я делаю, как показано на рисунке [censored]://devtrainingforum.v8.1c.ru/forum/mess_files/1_I..
но у меня выдаёт на синтаксическую ошибку
 
 
0 #3 olja 04.06.2013 12:19
я имела в виду стандартную конфигурацию. я смотрела в бюджетной, уверена и в бухгалтерии предприятия тоже есть
 
 
0 #2 andrej 29.05.2013 00:30
а где взять это платежное поручение?
 
 
0 #1 olja 24.05.2013 18:02
недавно столкнулась с той же проблемой - посмотрела как это делается в платежном поручении и сделала аналогчино
 

You have no rights to post comments