• Mobile apps - просто как 2х2!

    Рост количества информации и ускорение темпов жизни все сильнее требует постоянного присутсвия в рабочей сети, в том числе и в пути. Именно поэтому такю большую популярность приобретают смартфоны, КПК и планшеты, представляющие собой мобильные компьютеры для доступа к рабочей и личной информации.

    Сегодня довольно сложно встретить человека без мобильного телефона или смартфона. Это уже не просто средство связи, но также и инструмент для работы, управления личными данными, общения в интернете, а также разного вида развлечений.

     
     
  • Аналитические данные

    Для иллюстрации разнообразных аналитических и научных данных довольно удобно использовать красивые диаграммы. Табличный редактор  от Microsoft Excel 2010 предлагает огромное количество как стандартных так и довольно редких диаграмм и позволяет создавать сложные комбинации из уже существующих шаблонов.

    Создать диаграмму в программе Excel 2010 довольно просто, так как, открывая эту программу, вам потребуется нажать всголишь пару кнопок. Остается всего лишь их заполнить таблицу с данными. Как же это сделать?Вы узнаете из статей нашего сайта.

     
  •  E-mail и рассылки

    Не секрет, что на сегодняшний день E-mail рассылка всё еще является эффективным рекламным средством, признанным во всей интернет среде, по соотношению цена качество. Охват массовой рассылки соизмерим, разве, что с рекламой по телефону

    Маркетинг путем рассылок по электронной почте позволяет создать необходимую программу регулярных рассылок для продвижения своего бренла и развития бизнеса в целом. Наконец, правильно построенный интернет маркетинг по почте может укрепить положительные взаимоотношения клиентов и организации.

     
  • Мобильные устройства

    Новости, обзоры и тесты портативной техники и мобильных устройств. Современные смартфоны, КПК и планшеты содержат в себе довольно взрослый функционал, аналогичный такому же у своих «старших братьев». Удаленное администрирование, браузеры с технологиями flash и java-script, синхронизация электронной почты, заметок, обмен различными файлами. Обо всем этом и не только подробнее на нашем сайте.

7.7 Добавление строки в табличную часть

Категория Помощь

В табличной Части документа(Наименование,Цена,Колво //заданы Наименование и Колво) при клике по колонке "Цена" Выползает предложение:"Введите цену для всех одинаковых наименований"(Сравнение идет по текущему наименованию)-> указываем цену..Дальше след. вопрос:"Для какого кол-ва?" -> Указываем нужное кол-во. Так вот,если указанное колво больше,чем у нас имеется, должна ввестись НоваяСтрока, в которую вводится практически вся таже самая информация только с недостающим колвом. ОН НЕ ДОБАВЛЯЕТ!!!!!!!!попробовала выгрузить ТаблЧАсть в ТЗ и добавить туда НовуюСтроку - он пишет всю нужную инфо, ТОЛЬКО!! НомерСтроки=0. Почему? Хотя добавление новой строки спомощью кнопки прокатывает без проблем! В табличной Части документа(Наименование,Цена,Колво //заданы Наименование и Колво) при клике по колонке "Цена" Выползает предложение:"Введите цену для всех одинаковых наименований"(Сравнение идет по текущему наименованию)-> указываем цену..Дальше след. вопрос:"Для какого кол-ва?" -> Указываем нужное кол-во. Так вот,если указанное колво больше,чем у нас имеется, должна ввестись НоваяСтрока, в которую вводится практически вся таже самая информация только с недостающим колвом. ОН НЕ ДОБАВЛЯЕТ!!!!!!!!
попробовала выгрузить ТаблЧАсть в ТЗ и добавить туда НовуюСтроку - он пишет всю нужную инфо, ТОЛЬКО!! НомерСтроки=0. Почему? Хотя добавление новой строки спомощью кнопки прокатывает без проблем!

Комментарии  

 
0 #8 aleksand 25.07.2013 03:12
Да вот и дело, что она только там и срабатывает :( А хотелось бы...
Ну я уже сделала по-другому :) Спасибо всем!!!
 
 
0 #7 tatjana 19.06.2013 02:12
НоваяСтрока(); срабатывает только в предопределенно й процедуре.
Например "ПриОкончанииРе дактирования Строки()", "ОбработкаПодбора()".
Я точно не знаю, но мне так кажется.
Получается, что ты все ещё обрабатваешь строку текущую, и при этом хочешь завести новую.
Попробуй изменить подход.
 
 
0 #6 aleksand 18.06.2013 21:12
Процедура Ввести(ИмяРекви зита)
Если Наименование.Вы бран() = 1 Тогда
Наим=Наименован ие;
Если (ИмяРеквизита = "Цена") Тогда
Ч=Цена; Ч1=1; К=0;
Если ВвестиЧисло(Ч," Введите цену для всех
" Наименование,10 ,2,0)=1 Тогда
Если ВвестиЧисло(Ч1, "Для какого кол-ва? ",10,0,0)=1 Тогда
ВыбратьСтроки() ;
Пока ПолучитьСтроку( )=1 Цикл
//считаем количество одинаковых
Если СокрЛП(Наименов ание) = СокрЛП(Наим) Тогда
К=К Количество;
КонецЕсли;
КонецЦикла;
Если К<Ч1 Тогда//И если введенное кол-во>того,что есть,то
НоваяСтрока();
Наименование=На им;
Цена = Ч;
Пересчет("Цена" );
Форма.Обновить( 1);
Сообщить("Добав ил новую строку");
Иначе ....
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КОнецПроцедуры
 
 
0 #5 pavel 17.06.2013 14:45
Выложи код обработки события клика по колонке "Цена" и где там у тебя добавляется новая строка
 
 
0 #4 tatjana 16.06.2013 05:56
имхо.. если последним редактируется количество то на Количество и стоит весить добавление строки.. или я что то не понимаю...
 
 
0 #3 aleksand 15.06.2013 21:19
На 1С7.7.Не могу добавить НовуюСтроку в табл.часть из процедуры,повеш анной на колонку ЦЕНА в табл.части.
 
 
0 #2 vladimir 11.06.2013 17:30
проблема то в чем? не можешь прогнать обработку которая вопросы задает в отладке? вычислить обработку не можешь?
 
 
0 #1 tatjana 09.06.2013 13:38
По подробнее.. 8-ка? На какой обработчик добавление строки повесила? Отладкой пробовала юзать?
 

You have no rights to post comments