• Mobile apps - просто как 2х2!

    Рост количества информации и ускорение темпов жизни все сильнее требует постоянного присутсвия в рабочей сети, в том числе и в пути. Именно поэтому такю большую популярность приобретают смартфоны, КПК и планшеты, представляющие собой мобильные компьютеры для доступа к рабочей и личной информации.

    Сегодня довольно сложно встретить человека без мобильного телефона или смартфона. Это уже не просто средство связи, но также и инструмент для работы, управления личными данными, общения в интернете, а также разного вида развлечений.

     
     
  • Аналитические данные

    Для иллюстрации разнообразных аналитических и научных данных довольно удобно использовать красивые диаграммы. Табличный редактор  от Microsoft Excel 2010 предлагает огромное количество как стандартных так и довольно редких диаграмм и позволяет создавать сложные комбинации из уже существующих шаблонов.

    Создать диаграмму в программе Excel 2010 довольно просто, так как, открывая эту программу, вам потребуется нажать всголишь пару кнопок. Остается всего лишь их заполнить таблицу с данными. Как же это сделать?Вы узнаете из статей нашего сайта.

     
  •  E-mail и рассылки

    Не секрет, что на сегодняшний день E-mail рассылка всё еще является эффективным рекламным средством, признанным во всей интернет среде, по соотношению цена качество. Охват массовой рассылки соизмерим, разве, что с рекламой по телефону

    Маркетинг путем рассылок по электронной почте позволяет создать необходимую программу регулярных рассылок для продвижения своего бренла и развития бизнеса в целом. Наконец, правильно построенный интернет маркетинг по почте может укрепить положительные взаимоотношения клиентов и организации.

     
  • Мобильные устройства

    Новости, обзоры и тесты портативной техники и мобильных устройств. Современные смартфоны, КПК и планшеты содержат в себе довольно взрослый функционал, аналогичный такому же у своих «старших братьев». Удаленное администрирование, браузеры с технологиями flash и java-script, синхронизация электронной почты, заметок, обмен различными файлами. Обо всем этом и не только подробнее на нашем сайте.

Ручные операции

Категория Помощь

Если кто знает, подскажите самый простой способ вытаскивать суммы в отчёт, из ручных операции. Если кто знает, подскажите самый простой способ вытаскивать суммы в отчёт, из ручных операции.

Комментарии  

 
0 #9 dmitrij 21.07.2013 06:17
Анастасия Nastasia Андреева большое спасибо за совет.Но проблема была уже решена так.
Есть процедура

Развернуть(Ит,к ,Таб1,строчка,н аименование,Сум маВсего,Субконт о=0)
в ней пишем:

если Ит.КорСчет=Счет ПоКоду("1284") Тогда
Расшифровка.Уст ановить("КорСче т", Ит.КорСчет);
Ит.ВыбратьКорСу бконто();
Пока Ит.ПолучитьКорС убконто()=1 Цикл
Расшифровка.Уст ановить("КорСуб конто1",Ит.КорС убконто());
Ит.ВыбратьПерио ды();
ТзДок.УдалитьСт роки();
Пока Ит.ПолучитьПери од()=1 Цикл
ТзДок.УдалитьСт роки();
Док = Ит.Операция.Док умент.ТекущийДо кумент();
Если (Док.Вид()="Опе рация") Тогда
Если к=0 Тогда
Таб1.ВывестиСек цию("Шапка");
к=1;
КонецЕсли;
Док.ВыбратьСтро ки();
Опер = Док.Операция;
Сумма = 0;
Опер.выбратьпро водки();
Пока Опер.получитьпр оводку()=1 Цикл
если (опер.дебет.сче т=счетпокоду("1 310")) или (опер.дебет.сче т=счетпокоду("1 313")) или (опер.дебет.сче т=счетпокоду("1 350")) тогда
РНН=Ит.КорСубко нто().РНН;
БИН=Ит.КорСубко нто().БИН;
ПлатПор=Ит.КорС убконто();
Если ПустаяСтрока(РН Н)=1 Тогда
Сообщить("Нет РНН: " Ит.КорСубконто( ).Наименование) ;
КонецЕсли;
нпп=нпп 1;
Тз.НоваяСтрока( );
сумма=опер.сумм а;
Тз.Рнн = РНН;
Тз.бин = БИН;
ТЗ.Сумма=Сумма;
Тз.Строка=Строч ка;
Таб1.ВывестиСек цию("Строка");
СуммаВсего=Сумм аВсего Сумма;
конецесли;
конеццикла;

Затем в процедуре Сформировать() вызываем наш разворот:

Ит= СоздатьОбъект( "БухгалтерскиеИ тоги" );
Ит.ВключатьСубс чета(-1,-1);
Ит.Использовать РазделительУчет а(РазделительУч ета);
Ит.Использовать КорСубконто(Вид ыСубконто.Контр агенты);

Ит.ВыполнитьЗап рос(Дата1,Дата2 ,,,,2,"Операция ");
нпп=0; к=0; СуммаВсего=0;Су ммаВсегоА=0;
наименование="Т овары, сырье, материалы";
Ит.ВыбратьСчета ();
Пока Ит.ПолучитьСчет ()=1 Цикл
Если ((Лев(Ит.Счет,3 )="131")и (Лев(Ит.Счет,4) <>"1311")) или (сокрлп(Ит.Счет )="1350")или (сокрлп(Ит.Счет )="1330") или (сокрлп(Ит.Счет )="1312") или (сокрлп(Ит.Счет )="1320") Тогда
Расшифровка.Уст ановить("Счет", Ит.Счет);
Сумма=0;
Ит.ВыбратьКорСч ета();
Развернуть(Ит,к ,Таб1,строчка,н аименование,Сум ма);
Сообщить(Ит.Сче т.Код " " Строка(Сумма));
СуммаВсегоА=Сум маВсегоА Сумма;
СуммаВсего = СуммаВсего Сумма;
КонецЕсли;
КонецЦикла;
 
 
0 #8 anastasi 20.07.2013 18:57
Нужно брать остатки и обороты по нужным счетам учета и все... а для этого есть встроенный язык и объект :
БИ = СоздатьОбъект " Бухгалтерские Итоги"
БИ. Выпролнить запрос (параметры согласно требованиям ) и т.д.
А далее уже выбираете те счета и суммы, которые нужны - скорее всего остатки БИ. СКК(<параметры> ) или или БИ.СКД(<парамет ры>) в зависимости от счетов и все... А далее уже нужно смотреть , чем остаток сформирован - специализирован ным доком при проведении или - операцией и выбирать нужный...
 
 
0 #7 dmitrij 14.07.2013 15:30
#6
Операции я собственно не вношу, мне нужно просто их вытащить в отчет.Ну например таможенные платежи.

#7
Не понял сокращения насчет оборотки, поэтому переспросил.
 
 
0 #6 andrej 06.07.2013 21:40
ОСВ это оборотно-сальдо вая ведомость, если в любой бухгалтерии
 
 
0 #5 dmitrij 03.07.2013 17:14
А какие операции вы вводите вручную?
 
 
0 #4 dmitrij 02.07.2013 23:07
Версия 7.7, но конфиг не типовой.Можно примерчик ОСВ отчета.Ни разу не сталкивался с ним.
 
 
0 #3 andrej 29.06.2013 20:14
если в 7.7 то там все идет по бухгалтерским итогам, возьми отчет ОСВ за основу
 
 
0 #2 roman 27.06.2013 04:19
Ручные операции создают проводки по своим регистрам, из регистров и вытаскивай суммы.
 
 
0 #1 urij 26.06.2013 21:56
Какая версия 7.7 или 8.х???
Что Вы подразумеваете под "ручными операциями"???
 

You have no rights to post comments