• Mobile apps - просто как 2х2!

    Рост количества информации и ускорение темпов жизни все сильнее требует постоянного присутсвия в рабочей сети, в том числе и в пути. Именно поэтому такю большую популярность приобретают смартфоны, КПК и планшеты, представляющие собой мобильные компьютеры для доступа к рабочей и личной информации.

    Сегодня довольно сложно встретить человека без мобильного телефона или смартфона. Это уже не просто средство связи, но также и инструмент для работы, управления личными данными, общения в интернете, а также разного вида развлечений.

     
     
  • Аналитические данные

    Для иллюстрации разнообразных аналитических и научных данных довольно удобно использовать красивые диаграммы. Табличный редактор  от Microsoft Excel 2010 предлагает огромное количество как стандартных так и довольно редких диаграмм и позволяет создавать сложные комбинации из уже существующих шаблонов.

    Создать диаграмму в программе Excel 2010 довольно просто, так как, открывая эту программу, вам потребуется нажать всголишь пару кнопок. Остается всего лишь их заполнить таблицу с данными. Как же это сделать?Вы узнаете из статей нашего сайта.

     
  •  E-mail и рассылки

    Не секрет, что на сегодняшний день E-mail рассылка всё еще является эффективным рекламным средством, признанным во всей интернет среде, по соотношению цена качество. Охват массовой рассылки соизмерим, разве, что с рекламой по телефону

    Маркетинг путем рассылок по электронной почте позволяет создать необходимую программу регулярных рассылок для продвижения своего бренла и развития бизнеса в целом. Наконец, правильно построенный интернет маркетинг по почте может укрепить положительные взаимоотношения клиентов и организации.

     
  • Мобильные устройства

    Новости, обзоры и тесты портативной техники и мобильных устройств. Современные смартфоны, КПК и планшеты содержат в себе довольно взрослый функционал, аналогичный такому же у своих «старших братьев». Удаленное администрирование, браузеры с технологиями flash и java-script, синхронизация электронной почты, заметок, обмен различными файлами. Обо всем этом и не только подробнее на нашем сайте.

Не формирует проводки!!! подскажите что не так

Категория Помощь

Запрос = Новый Запрос;Запрос.Текст = "ВЫБРАТЬ| ХозрасчетныйОстатки.СуммаОстатокДт,| ХозрасчетныйОстатки.Субконто1,| ХозрасчетныйОстатки.Субконто2,| ХозрасчетныйОстатки.Организация,| ХозрасчетныйОстатки.Счет,| ХозрасчетныйОстатки.СуммаОстатокКт|ИЗ| РегистрБухгалтерии.Хозрасчетный.Остатки(| &Период,| Счет = &Счет,| ,| Субконто1 = &Контрагент| И Организация = &Организация| И Субконто2 = &Договор) КАК ХозрасчетныйОстатки";Запрос.УстановитьПараметр("Период", Период);Запрос.УстановитьПараметр("Контрагент", Контрагент);Запрос.УстановитьПараметр("Договор", Договор);Запрос.УстановитьПараметр("Организация", Организация);Запрос.УстановитьПараметр("Счет", ПланыСчетов.Хозрасчетный.РасчетыСПрочимиПоставщикамиИПодрядчиками);Выборка = Запрос.Выполнить().Выбрать();Если Выборка.Следующий() ТогдаДатаЗаписи = Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
| ХозрасчетныйОстатки.СуммаОстатокДт,
| ХозрасчетныйОстатки.Субконто1,
| ХозрасчетныйОстатки.Субконто2,
| ХозрасчетныйОстатки.Организация,
| ХозрасчетныйОстатки.Счет,
| ХозрасчетныйОстатки.СуммаОстатокКт
|ИЗ
| РегистрБухгалтерии.Хозрасчетный.Остатки(
| &Период,
| Счет = &Счет,
| ,
| Субконто1 = &Контрагент
| И Организация = &Организация
| И Субконто2 = &Договор) КАК ХозрасчетныйОстатки";

Запрос.УстановитьПараметр("Период", Период);
Запрос.УстановитьПараметр("Контрагент", Контрагент);
Запрос.УстановитьПараметр("Договор", Договор);
Запрос.УстановитьПараметр("Организация", Организация);
Запрос.УстановитьПараметр("Счет", ПланыСчетов.Хозрасчетный.РасчетыСПрочимиПоставщикамиИПодрядчиками);

Выборка = Запрос.Выполнить().Выбрать();

Если Выборка.Следующий() Тогда

ДатаЗаписи = ТекущаяДата();
Документ = Документы.ОперацияБух.СоздатьДокумент();
Документ.Дата = ДатаЗаписи;
Документ.Организация = Организация;
Документ.Содержание = "Закрытие счета 76";
Документ.Записать(РежимЗаписиДокумента.Проведение);

Проводка = Документ.Движения.Хозрасчетный.Добавить();
Проводка.СчетДт = ПланыСчетов.Хозрасчетный.РасчетыСПрочимиПоставщикамиИПодрядчиками;
Проводка.СчетКт = ПланыСчетов.Хозрасчетный.РасчетыПоДоговоруДоверительногоУправленияИмуществом;
Проводка.СубконтоДт.Контрагенты = Контрагент;
Проводка.СубконтоДт.Договоры = Договор;
Проводка.Сумма = Выборка.СуммаОстатокДт;

Проводка2 = Документ.Движения.Хозрасчетный.Добавить();
Проводка2.СчетДт = ПланыСчетов.Хозрасчетный.ЗакрытиеСчета76;
Проводка2.СчетКт = ПланыСчетов.Хозрасчетный.РасчетыСПрочимиПоставщикамиИПодрядчиками;
Проводка2.СубконтоКт.Контрагенты = Контрагент;
Проводка2.СубконтоКт.Договоры = Договор;
Проводка2.Сумма = Выборка.СуммаОстатокКт;

Документ.СуммаОперации = Выборка.СуммаОстатокДт Выборка.СуммаОстатокКт;

КонецЕсли;

Комментарии  

 
0 #21 danis 30.07.2013 01:28
ошибка выходит

{Обработка.ЗакрытиеСчета.Форма.Форма(22,40)}: Процедура или функция с указанным именем не определена (НовыйГраница)
Запрос.УстановитьПараметр("Период", <>НовыйГрани ца(Период, ВидГраницы.Вклю чая));
 
 
0 #20 tatjana 29.07.2013 02:35
Просто нужно правильно параметры установить:
Запрос.УстановитьПараметр("Период", НовыйГраница(Пе риод, ВидГраницы.Включая));

Для пущей уверенности, что документ попал в период выбора остатков, брать дату на конец дня, но это уже нюансы ..
 
 
0 #19 danis 24.07.2013 17:13
вот еще проблема только. при повторном выполнении обработки почему то создает такие же проводки, их же не должно быть я так понимаю????

и как бы еще сделать чтобы при нулевых остатках не создавались проводки?
 
 
0 #18 danis 14.07.2013 07:29
Процедура КнопкаВыполнитьНажатие(Кнопка)

Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
| ХозрасчетныйОстатки.СуммаОстатокДт,
| ХозрасчетныйОстатки.Субконто1,
| ХозрасчетныйОстатки.Субконто2,
| ХозрасчетныйОстатки.Организация,
| ХозрасчетныйОстатки.Счет,
| ХозрасчетныйОстатки.СуммаОстатокКт
|ИЗ
| РегистрБухгалте рии.Хозрасчетны й.Остатки(&Пери од, Счет = &Счет, , Организация = &Организация) КАК ХозрасчетныйОстатки";

Запрос.УстановитьПараметр("Период", Период);
Запрос.УстановитьПараметр("Контрагент", Контрагент);
Запрос.УстановитьПараметр("Договор", Договор);
Запрос.УстановитьПараметр("Организация", Организация);
Запрос.УстановитьПараметр("Счет", ПланыСчетов.Хозрасчетный.РасчетыСПрочимиПоставщикамиИПодрядчиками);

Выборка = Запрос.Выполнить().Выбрать();

Если Выборка.Количес тво() <> 0 Тогда
ДатаЗаписи = ТекущаяДата();
Документ = Документы.ОперацияБух.СоздатьДокумент();
Документ.Дата = ДатаЗаписи;
Документ.Организация = Организация;
Документ.Содержание = "Закрытие счета 76";

Пока Выборка.Следующ ий() Цикл

ПроводкиБУ = Документ.Движения.Хозрасчетный;

Проводка = ПроводкиБУ.Добавить();
Проводка.Активность = Истина;
Проводка.Период = Период;
Проводка.СчетКт = ПланыСчетов.Хозрасчетный.РасчетыСПрочимиПоставщикамиИПодрядчиками;
Проводка.СчетДт = ПланыСчетов.Хозрасчетный.РасчетыПоДоговоруДоверительногоУправленияИмуществом;
Проводка.СубконтоДт.Контрагенты = Выборка.Субконто1;
Проводка.СубконтоДт.Договоры = Выборка.Субконто2;
Проводка.СубконтоКт.Контрагенты = Выборка.Субконто1;
Проводка.СубконтоКт.Договоры = Выборка.Субконто2;

Проводка.Сумма = Выборка.СуммаОс татокДт;

Проводка = Документ.Движения.Хозрасчетный.Добавить();
Проводка.Активность = Истина;
Проводка.Период = Период;
Проводка.СчетКт = ПланыСчетов.Хозрасчетный.РасчетыПоДоговоруДоверительногоУправленияИмуществом;
Проводка.СчетДт = ПланыСчетов.Хозрасчетный.РасчетыСПрочимиПоставщикамиИПодрядчиками;
Проводка.СубконтоКт.Контрагенты = Выборка.Субконто1;
Проводка.СубконтоКт.Договоры = Выборка.Субконто2;
Проводка.СубконтоДт.Контрагенты = Выборка.Субконто1;
Проводка.СубконтоДт.Договоры = Выборка.Субконто2;

Проводка.Сумма = Выборка.СуммаОстатокКт;

Документ.СуммаОперации = Выборка.СуммаОс татокДт Выборка.СуммаОстатокКт;

КонецЦикла;
Документ.Записать();

Форма = Документ.ПолучитьФорму();
Форма.Открыть();
КонецЕсли;
КонецПроцедуры
 
 
0 #17 danis 10.07.2013 21:08
большое спасибо за советы. все получилось вот с таким кодом:
 
 
0 #16 tatjana 10.07.2013 00:15
А что делает? остатки задваивает? может Дт с Кт поменять местами нуна?))
 
 
0 #15 danis 05.07.2013 23:01
Процедура КнопкаВыполнитьНажатие(Кнопка)

Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
| ХозрасчетныйОстатки.СуммаОстатокДт,
| ХозрасчетныйОстатки.Субконто1,
| ХозрасчетныйОстатки.Субконто2,
| ХозрасчетныйОстатки.Организация,
| ХозрасчетныйОстатки.Счет,
| ХозрасчетныйОстатки.СуммаОстатокКт
|ИЗ
| РегистрБухгалте рии.Хозрасчетны й.Остатки(&Пери од, Счет = &Счет, , Организация = &Организация) КАК ХозрасчетныйОстатки";

Запрос.УстановитьПараметр("Период", Период);
Запрос.УстановитьПараметр("Контрагент", Контрагент);
Запрос.УстановитьПараметр("Договор", Договор);
Запрос.УстановитьПараметр("Организация", Организация);
Запрос.УстановитьПараметр("Счет", ПланыСчетов.Хозрасчетный.РасчетыСПрочимиПоставщикамиИПодрядчиками);

Выборка = Запрос.Выполнить().Выбрать();

Если Выборка.Количес тво() <> 0 Тогда
ДатаЗаписи = ТекущаяДата();
Документ = Документы.ОперацияБух.СоздатьДокумент();
Документ.Дата = ДатаЗаписи;
Документ.Организация = Организация;
Документ.Содержание = "Закрытие счета 76";

Пока Выборка.Следующ ий() Цикл

ПроводкиБУ = Документ.Движения.Хозрасчетный;

Проводка = ПроводкиБУ.Добавить();
Проводка.Период = Период;
Проводка.СчетДт = ПланыСчетов.Хозрасчетный.РасчетыСПрочимиПоставщикамиИПодрядчиками;
Проводка.СчетКт = ПланыСчетов.Хозрасчетный.РасчетыПоДоговоруДоверительногоУправленияИмуществом;
Проводка.СубконтоДт.Контрагенты = Выборка.Субконто1;
Проводка.СубконтоДт.Договоры = Выборка.Субконто2;
Проводка.СубконтоКт.Контрагенты = Выборка.Субконто1;
Проводка.СубконтоКт.Договоры = Выборка.Субконто2;

Проводка.Сумма = Выборка.СуммаОстатокДт;

Документ.СуммаОперации = Выборка.СуммаОстатокДт;

КонецЦикла;
Документ.Записать();

Форма = Документ.ПолучитьФорму();
Форма.Открыть();
КонецЕсли;
КонецПроцедуры
 
 
0 #14 danis 02.07.2013 14:54
спасибо. вроде как проводки формирует, но не переносит остатки на другой счет...
 
 
0 #13 tatjana 30.06.2013 21:45
Если Выборка.Количес тво() <> 0 Тогда
// Создать документ
Пока Выборка.Следующ ий() Цикл
// Добавлять движения
КонецЦикла;
// Записать документ, открыть форму
КонецЕсли;
 
 
0 #12 danis 28.06.2013 12:08
Процедура КнопкаВыполнитьНажатие(Кнопка)

Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
| ХозрасчетныйОстатки.СуммаОстатокДт,
| ХозрасчетныйОстатки.Субконто1,
| ХозрасчетныйОстатки.Субконто2,
| ХозрасчетныйОстатки.Организация,
| ХозрасчетныйОстатки.Счет,
| ХозрасчетныйОстатки.СуммаОстатокКт
|ИЗ
| РегистрБухгалте рии.Хозрасчетны й.Остатки(&Пери од, Счет = &Счет, , Организация = &Организация) КАК ХозрасчетныйОстатки";

Запрос.УстановитьПараметр("Период", Период);
Запрос.УстановитьПараметр("Контрагент", Контрагент);
Запрос.УстановитьПараметр("Договор", Договор);
Запрос.УстановитьПараметр("Организация", Организация);
Запрос.УстановитьПараметр("Счет", ПланыСчетов.Хозрасчетный.РасчетыСПрочимиПоставщикамиИПодрядчиками);

Выборка = Запрос.Выполнить().Выбрать();

Если Выборка.Следующ ий() Тогда

ДатаЗаписи = ТекущаяДата();
Документ = Документы.ОперацияБух.СоздатьДокумент();
Документ.Дата = ДатаЗаписи;
Документ.Организация = Организация;
Документ.Содержание = "Закрытие счета 76";

ПроводкиБУ = Документ.Движения.Хозрасчетный;

Проводка = ПроводкиБУ.Добавить();
Проводка.Период = Период;
Проводка.СчетДт = ПланыСчетов.Хозрасчетный.РасчетыСПрочимиПоставщикамиИПодрядчиками;
Проводка.СчетКт = ПланыСчетов.Хозрасчетный.РасчетыПоДоговоруДоверительногоУправленияИмуществом;
Проводка.СубконтоДт.Контрагенты = Контрагент;
Проводка.СубконтоДт.Договоры = Договор;
Проводка.Сумма = Выборка.СуммаОс татокДт;

Проводка = Документ.Движения.Хозрасчетный.Добавить();
Проводка.Период = Период;
Проводка.СчетДт = ПланыСчетов.Хозрасчетный.РасчетыПоДоговоруДоверительногоУправленияИмуществом;
Проводка.СчетКт = ПланыСчетов.Хозрасчетный.РасчетыСПрочимиПоставщикамиИПодрядчиками;
Проводка.СубконтоКт.Контрагенты = Контрагент;
Проводка.СубконтоКт.Договоры = Договор;
Проводка.Сумма = Выборка.СуммаОстатокКт;

Документ.СуммаОперации = Выборка.СуммаОс татокДт Выборка.СуммаОстатокКт;

Документ.Записать();

Форма = Документ.ПолучитьФорму();
Форма.Открыть();

КонецЕсли;

КонецПроцедуры
 
 
0 #11 danis 24.06.2013 06:27
спасибо за советы, проверил запрос, чуть изменил, теперь данные для выборки есть, но в документ выносит только одну проводку и почему то не заполняются данные субконто

код обработки этот:
 
 
0 #10 tatjana 20.06.2013 12:57
Судя по коду, документ создается, если в запросе есть хоть что нить. В результате запроса есть что нибудь? Думаю, что нет, иначе у Вас ошибка была бы, описанная в посте 8 и 10.
 
 
0 #9 danis 20.06.2013 00:42
в предприятии запускаю обработку, выбираю организацию, период-месяц, нажимаю выполнить, документа с проводками не появляется
 
 
0 #8 danis 18.06.2013 09:21
Процедура КнопкаВыполнитьНажатие(Кнопка)

Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
| ХозрасчетныйОстатки.СуммаОстатокДт,
| ХозрасчетныйОстатки.Субконто1,
| ХозрасчетныйОстатки.Субконто2,
| ХозрасчетныйОстатки.Организация,
| ХозрасчетныйОстатки.Счет,
| ХозрасчетныйОстатки.СуммаОстатокКт
|ИЗ
| РегистрБухгалтерии.Хозрасчетный.Остатки(
| &Период,
| Счет = &Счет,
| ,
| Субконто1 = &Контрагент
| И Организация = &Организация
| И Субконто2 = &Договор) КАК ХозрасчетныйОстатки";

Запрос.УстановитьПараметр("Период", Период);
Запрос.УстановитьПараметр("Контрагент", Контрагент);
Запрос.УстановитьПараметр("Договор", Договор);
Запрос.УстановитьПараметр("Организация", Организация);
Запрос.УстановитьПараметр("Счет", ПланыСчетов.Хозрасчетный.РасчетыСПрочимиПоставщикамиИПодрядчиками);

Выборка = Запрос.Выполнить().Выбрать();

Если Выборка.Следующ ий() Тогда

ДатаЗаписи = ТекущаяДата();
Документ = Документы.ОперацияБух.СоздатьДокумент();
Документ.Дата = ДатаЗаписи;
Документ.Организация = Организация;
Документ.Содержание = "Закрытие счета 76";
//Документ.Записать(РежимЗаписиДокумента.Проведение);

ПроводкиБУ = Документ.Движения.Хозрасчетный;

Проводка = ПроводкиБУ.Добавить();
Проводка.СчетДт = ПланыСчетов.Хозрасчетный.РасчетыСПрочимиПоставщикамиИПодрядчиками;
Проводка.СчетКт = ПланыСчетов.Хозрасчетный.РасчетыПоДоговоруДоверительногоУправленияИмуществом;
Проводка.СубконтоДт.Контрагент = Контрагент;
Проводка.СубконтоДт.Договоры = Договор;
Проводка.Сумма = Выборка.СуммаОс татокДт;

Проводка= Документ.Движения.Хозрасчетный.Добавить();
Проводка.СчетДт = ПланыСчетов.Хозрасчетный.РасчетыПоДоговоруДоверительногоУправленияИмуществом;
Проводка.СчетКт = ПланыСчетов.Хозрасчетный.РасчетыСПрочимиПоставщикамиИПодрядчиками;
Проводка.СубконтоКт.Контрагенты = Контрагент;
Проводка.СубконтоКт.Договоры = Договор;
Проводка.Сумма = Выборка.СуммаОстатокКт;

Документ.СуммаОперации = Выборка.СуммаОс татокДт Выборка.СуммаОстатокКт;

Документ.Записать();

Форма = Документ.ПолучитьФорму();
Форма.Открыть();

КонецЕсли;

КонецПроцедуры
 
 
0 #7 danis 17.06.2013 23:59
#10: все это реализуется в обработке. для обработки созданы реквизиты: организация(Спр авочникСсылка.О рганизации), период(Дата), контрагент(Спра вочникСсылка.Ко нтрагенты), договор(Справоч никСсылка.Догов орыКонтрагентов ). создана основная форма с процедурами в модуле формы
 
 
0 #6 tatjana 13.06.2013 13:40
#8: конечно нет, тупо скопировала, поправив запись. Тут нужно воспользоваться : СубконтоДт[ПВХ. Хозрасчетный.Ко нтрагенты] = Контрагент; либо УстановитьСубко нто (насчет последнего неуверена, т.к. не пробовала).
#9: чтобы документ появился нужно форму его открыть:
Форма = Документ.ПолучитьФорму();
Форма.Открыть();
или что Вы имеете в виду под его появлением?
 
 
0 #5 danis 12.06.2013 19:18
также никакой документ не появляется
 
 
0 #4 sergej 11.06.2013 18:44
К #6 Вы уверены по поводу "Проводка.Субко нтоДт.Контраген ты = Контрагент;"? Почему не воспользоваться "УстановитьСубк нто"?
 
 
0 #3 dmitrij 09.06.2013 10:56
#6:Судя по коду это идет либо во внешней обработке, либо из другого места конфигурации, поэтому Сергей от части прав.
 
 
0 #2 tatjana 01.06.2013 14:59
Если Выборка.Следующ ий() Тогда

ДатаЗаписи = ТекущаяДата();
Документ = Документы.ОперацияБух.СоздатьДокумент();
Документ.Дата = ДатаЗаписи;
Документ.Организация = Организация;
Документ.Содержание = "Закрытие счета 76";
//Документ.Записать(РежимЗаписиДокумента.Проведение);

ПроводкиБУ = Документ.Движения.Хозрасчетный;

Проводка = ПроводкиБУ.Добавить();
Проводка.СчетДт = ПланыСчетов.Хозрасчетный.РасчетыСПрочимиПоставщикамиИПодрядчиками;
Проводка.СчетКт = ПланыСчетов.Хозрасчетный.РасчетыПоДоговоруДоверительногоУправленияИмуществом;
Проводка.СубконтоДт.Контрагенты = Контрагент;
Проводка.СубконтоДт.Договоры = Договор;
Проводка.Сумма = Выборка.СуммаОс татокДт;

Проводка= Документ.Движения.Хозрасчетный.Добавить();
Проводка.СчетДт = ПланыСчетов.Хозрасчетный.ЗакрытиеСчета76;
Проводка.СчетКт = ПланыСчетов.Хозрасчетный.РасчетыСПрочимиПоставщикамиИПодрядчиками;
Проводка.СубконтоКт.Контрагенты = Контрагент;
Проводка.СубконтоКт.Договоры = Договор;
Проводка.Сумма = Выборка.СуммаОстатокКт;

Документ.СуммаОперации = Выборка.СуммаОс татокДт Выборка.СуммаОстатокКт;

Документ.Записать();

КонецЕсли;
 
 
0 #1 sergej 01.06.2013 07:41
Это документ ОПЕРАЦИЯ. У него нет движений. Вам необходимо у движений установить РЕГИСТРАТОР и только тогда будут движения.
 

You have no rights to post comments