• Mobile apps - просто как 2х2!

    Рост количества информации и ускорение темпов жизни все сильнее требует постоянного присутсвия в рабочей сети, в том числе и в пути. Именно поэтому такю большую популярность приобретают смартфоны, КПК и планшеты, представляющие собой мобильные компьютеры для доступа к рабочей и личной информации.

    Сегодня довольно сложно встретить человека без мобильного телефона или смартфона. Это уже не просто средство связи, но также и инструмент для работы, управления личными данными, общения в интернете, а также разного вида развлечений.

     
     
  • Аналитические данные

    Для иллюстрации разнообразных аналитических и научных данных довольно удобно использовать красивые диаграммы. Табличный редактор  от Microsoft Excel 2010 предлагает огромное количество как стандартных так и довольно редких диаграмм и позволяет создавать сложные комбинации из уже существующих шаблонов.

    Создать диаграмму в программе Excel 2010 довольно просто, так как, открывая эту программу, вам потребуется нажать всголишь пару кнопок. Остается всего лишь их заполнить таблицу с данными. Как же это сделать?Вы узнаете из статей нашего сайта.

     
  •  E-mail и рассылки

    Не секрет, что на сегодняшний день E-mail рассылка всё еще является эффективным рекламным средством, признанным во всей интернет среде, по соотношению цена качество. Охват массовой рассылки соизмерим, разве, что с рекламой по телефону

    Маркетинг путем рассылок по электронной почте позволяет создать необходимую программу регулярных рассылок для продвижения своего бренла и развития бизнеса в целом. Наконец, правильно построенный интернет маркетинг по почте может укрепить положительные взаимоотношения клиентов и организации.

     
  • Мобильные устройства

    Новости, обзоры и тесты портативной техники и мобильных устройств. Современные смартфоны, КПК и планшеты содержат в себе довольно взрослый функционал, аналогичный такому же у своих «старших братьев». Удаленное администрирование, браузеры с технологиями flash и java-script, синхронизация электронной почты, заметок, обмен различными файлами. Обо всем этом и не только подробнее на нашем сайте.

Остатки

Категория Помощь

Подскажите кто-нибудь, делаю прогу, по торговле, платформа 1с 8.1, необходимо чтоб в справочнике видны были остатки, как это реализовать? Подскажите кто-нибудь, делаю прогу, по торговле, платформа 1с 8.1, необходимо чтоб в справочнике видны были остатки, как это реализовать?

Комментарии  

 
0 #13 evgenija 30.07.2013 22:56
Михаил Шалимов, спасибо за ссылку,она мне очень помогла! у меня всё получилось=)

Денис Фонский я это делаю в своей разработке
 
 
0 #12 denis 27.07.2013 13:26
Так в торговле, остатки и так в справочнике видны, зачем велосипед изобретать?????
 
 
0 #11 mihail 15.07.2013 16:05
Забейте на мой кривой код, и смотрите тут:
[censored]://[censored].kb.mista.ru/article.php?id=310
 
 
0 #10 mihail 12.07.2013 13:06
при получении данных для справокникСписо к.Номенклатура соответственно.
 
 
0 #9 mihail 11.07.2013 08:50
Процедура НоменклатураПри ПолученииДанных (Элемент, ОформленияСтрок )

Для Каждого Строка ИЗ ОформленияСтрок Цикл
Если НЕ Строка.ДанныеСт роки.Ссылка.Это Группа Тогда
//Некрасиво и нехорошо...
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ ПЕРВЫЕ 1
| ХозрасчетныйОст атки.Количество Остаток
|ИЗ
| РегистрБухгалте рии.Хозрасчетны й.Остатки(&Дата , Счет = &Счет, , Субконто1 В (&Номенклатура) ) КАК ХозрасчетныйОст атки";
Запрос.Установи тьПараметр("Ном енклатура", Строка.ДанныеСт роки.Ссылка);
Запрос.Установи тьПараметр("Дат а", ТекущаяДата());
Запрос.Установи тьПараметр("Сче т", ПланыСчетов.Хоз расчетный.Товар ыНаСкладах);
Результат = Запрос.Выполнит ь().Выбрать();
Результат.Следу ющий();
Строка.Ячейки.О статок.Значение = Результат.Колич ествоОстаток;
КонецЕсли;
КонецЦикла;
КонецПроцедуры

не очень хорошо, но всеже работает. сделано под буху такойже код под УТ ненашел.
 
 
0 #8 sergej 08.07.2013 17:18
Там же написано
Значение не является значением объектного типа (Ячейки)
Пытаешься обратиться к тому, чего там нет. И, совсем не рационально, правда.
Два раза к выборке. Зачем? Ведь это и так в справочнике работает. Можно просто сразу ссылку передать.
 
 
0 #7 evgenija 05.07.2013 07:57
Там для меня как то сложновато, вот понять бы из-за чего эта ошибка вылазит...
 
 
0 #6 andrej 03.07.2013 14:51
В управлении торговлей при подборе видны остатки, там коды посмотри...
 
 
0 #5 evgenija 03.07.2013 08:17
Рустик [dumb851 3.0] Узбеков, спасибо, у меня получилось, но есть одно НО, остатки отражаются, но перед этим выскакивает ошибка:

{Справочник.Номенклатура.Форма.ФормаСписка(40)}: Значение не является значением объектного типа (Ячейки)
ОформлениеСтрокиПоНоменклатуре.Получить(Выборка.Номенклатура).Ячейки.Ост.Значение = Выборка.

Нажмешь "ок" и все показывает
 
 
0 #4 rustik 02.07.2013 22:45
открой книгу "Профессиональн ая разработка в системе 1С" Габец, Гончаров на странице 234.. там есть пример. Правда он не самый оптимальный, но всё же..
 
 
0 #3 sergej 01.07.2013 22:42
т.е.? Ну, делаешь запрос, при открытии формы. Из запроса получаешь выборку и выводишь в элементы формы или выгружаешь.
 
 
0 #2 evgenija 01.07.2013 15:35
а как из запроса взять данные? запрос то получается, но с помощью его у меня получаются только отчеты
 
 
0 #1 sergej 30.06.2013 17:20
При открытии формы делать запрос.
 

You have no rights to post comments