• Mobile apps - просто как 2х2!

    Рост количества информации и ускорение темпов жизни все сильнее требует постоянного присутсвия в рабочей сети, в том числе и в пути. Именно поэтому такю большую популярность приобретают смартфоны, КПК и планшеты, представляющие собой мобильные компьютеры для доступа к рабочей и личной информации.

    Сегодня довольно сложно встретить человека без мобильного телефона или смартфона. Это уже не просто средство связи, но также и инструмент для работы, управления личными данными, общения в интернете, а также разного вида развлечений.

     
     
  • Аналитические данные

    Для иллюстрации разнообразных аналитических и научных данных довольно удобно использовать красивые диаграммы. Табличный редактор  от Microsoft Excel 2010 предлагает огромное количество как стандартных так и довольно редких диаграмм и позволяет создавать сложные комбинации из уже существующих шаблонов.

    Создать диаграмму в программе Excel 2010 довольно просто, так как, открывая эту программу, вам потребуется нажать всголишь пару кнопок. Остается всего лишь их заполнить таблицу с данными. Как же это сделать?Вы узнаете из статей нашего сайта.

     
  •  E-mail и рассылки

    Не секрет, что на сегодняшний день E-mail рассылка всё еще является эффективным рекламным средством, признанным во всей интернет среде, по соотношению цена качество. Охват массовой рассылки соизмерим, разве, что с рекламой по телефону

    Маркетинг путем рассылок по электронной почте позволяет создать необходимую программу регулярных рассылок для продвижения своего бренла и развития бизнеса в целом. Наконец, правильно построенный интернет маркетинг по почте может укрепить положительные взаимоотношения клиентов и организации.

     
  • Мобильные устройства

    Новости, обзоры и тесты портативной техники и мобильных устройств. Современные смартфоны, КПК и планшеты содержат в себе довольно взрослый функционал, аналогичный такому же у своих «старших братьев». Удаленное администрирование, браузеры с технологиями flash и java-script, синхронизация электронной почты, заметок, обмен различными файлами. Обо всем этом и не только подробнее на нашем сайте.

Доступ к табличной части

Категория Помощь

Доброго времени суток. Извините если вопрос глупый, но все же. Как Получить данные строки табличной части справочника из внешнего отчета. 1с 8.1.Заранее благодарен. Доброго времени суток. Извините если вопрос глупый, но все же. Как Получить данные строки табличной части справочника из внешнего отчета. 1с 8.1.
Заранее благодарен.

Комментарии  

 
0 #2 sergej 02.07.2013 17:15
Сперва получить сам объект или ссылку на него, а дальше...
Для каждого СтрокаТЧ из СправочникСсылк а[ИмяТабличнойЧ асти] цикл
КонецЦикла;
 
 
0 #1 mihail 01.07.2013 06:52
Спр = Справочники.Най тиПоКоду("00000 01");//Или откуда ты его там берешь...
Для Каждого Стр Из Спр.ТЧ Цикл
Параметр1 = Стр.Реквизит1;
.....
КонецЦикла;

Или

Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
| СправочникСТЧТа бличнаяЧасть1.Р еквизит1,
| СправочникСТЧТа бличнаяЧасть1.Р еквизит2,
| СправочникСТЧТа бличнаяЧасть1.Р еквизит3,
| СправочникСТЧТа бличнаяЧасть1.С сылка.Код,
| СправочникСТЧТа бличнаяЧасть1.С сылка.Наименова ние,
| СправочникСТЧТа бличнаяЧасть1.С сылка.Реквизит1 КАК Реквизит11
|ИЗ
| Справочник.Спра вочникСТЧ.Табли чнаяЧасть1 КАК СправочникСТЧТа бличнаяЧасть1
|ГДЕ
| СправочникСТЧТа бличнаяЧасть1.С сылка.Реквизит1 = &Реквизит1";

Запрос.Установи тьПараметр("", );

Результат = Запрос.Выполнит ь();
Выборка = Результат.Выбра ть();

Пока Выборка.Следующ ий() Цикл



КонецЦикла;
 

You have no rights to post comments