• Mobile apps - просто как 2х2!

    Рост количества информации и ускорение темпов жизни все сильнее требует постоянного присутсвия в рабочей сети, в том числе и в пути. Именно поэтому такю большую популярность приобретают смартфоны, КПК и планшеты, представляющие собой мобильные компьютеры для доступа к рабочей и личной информации.

    Сегодня довольно сложно встретить человека без мобильного телефона или смартфона. Это уже не просто средство связи, но также и инструмент для работы, управления личными данными, общения в интернете, а также разного вида развлечений.

     
     
  • Аналитические данные

    Для иллюстрации разнообразных аналитических и научных данных довольно удобно использовать красивые диаграммы. Табличный редактор  от Microsoft Excel 2010 предлагает огромное количество как стандартных так и довольно редких диаграмм и позволяет создавать сложные комбинации из уже существующих шаблонов.

    Создать диаграмму в программе Excel 2010 довольно просто, так как, открывая эту программу, вам потребуется нажать всголишь пару кнопок. Остается всего лишь их заполнить таблицу с данными. Как же это сделать?Вы узнаете из статей нашего сайта.

     
  •  E-mail и рассылки

    Не секрет, что на сегодняшний день E-mail рассылка всё еще является эффективным рекламным средством, признанным во всей интернет среде, по соотношению цена качество. Охват массовой рассылки соизмерим, разве, что с рекламой по телефону

    Маркетинг путем рассылок по электронной почте позволяет создать необходимую программу регулярных рассылок для продвижения своего бренла и развития бизнеса в целом. Наконец, правильно построенный интернет маркетинг по почте может укрепить положительные взаимоотношения клиентов и организации.

     
  • Мобильные устройства

    Новости, обзоры и тесты портативной техники и мобильных устройств. Современные смартфоны, КПК и планшеты содержат в себе довольно взрослый функционал, аналогичный такому же у своих «старших братьев». Удаленное администрирование, браузеры с технологиями flash и java-script, синхронизация электронной почты, заметок, обмен различными файлами. Обо всем этом и не только подробнее на нашем сайте.

Получение Бух итогов через ОЛЕ

Категория Помощь

Похоже я где-то неуловимо торможу...Задача получение бухгалтерских итогов через ОЛЕКонфигурация Бу для Украины от АББИ 7.70.251 сильно переделанная..Почему: этот код нормально отрабатывает :-------------------------------------------------------------------------------------------------------Процедура Сформировать() перем БиоЛе ; Если ГлОлеПодключитьБазу(Агентство.ПутьКБухБазе,Агентство.ПользовательВБухБазе,Агентство.ПарольВБухБазе,Агентство.КодФирмы)=0 Тогда Возврат; КонецЕсли; ГлОлеБаза.EvalExpr("глБИ.ИспользоватьПланСчетов(ОсновнойПланСчетов())"); ГлОлеБаза.ExecuteBatch("глБИ.ИспользоватьСубконто(ВидыСубконто.ТМЦ)"); Если ГлОлеФирма 0 Тогда ГлОлеБаза.глБи.ИспользоватьРазделительУчета(ГлОлеФирма); КонецЕсли; ГлОлеБаза.глБи.ВыполнитьЗапрос(НачМесяца(ДатаН),НачМесяца(ДатаН),"281",,,1,,1 Похоже я где-то неуловимо торможу...

Задача получение бухгалтерских итогов через ОЛЕ
Конфигурация Бу для Украины от АББИ 7.70.251 сильно переделанная..
Почему: этот код нормально отрабатывает :
-------------------------------------------------------------------------------------------------------
Процедура Сформировать()
перем БиоЛе ;
Если ГлОлеПодключитьБазу(Агентство.ПутьКБухБазе,Агентство.ПользовательВБухБазе,Агентство.ПарольВБухБазе,Агентство.КодФирмы)=0 Тогда
Возврат;
КонецЕсли;
ГлОлеБаза.EvalExpr("глБИ.ИспользоватьПланСчетов(ОсновнойПланСчетов())");
ГлОлеБаза.ExecuteBatch("глБИ.ИспользоватьСубконто(ВидыСубконто.ТМЦ)");
Если ГлОлеФирма <> 0 Тогда
ГлОлеБаза.глБи.ИспользоватьРазделительУчета(ГлОлеФирма);
КонецЕсли;
ГлОлеБаза.глБи.ВыполнитьЗапрос(НачМесяца(ДатаН),НачМесяца(ДатаН),"281",,,1,,1);
БиОле=ГлОлеБаза.глБи;
БиОле.ВыбратьСубконто(1);
Пока БиОле.ПолучитьСубконто(1)=1 Цикл
сообщить( БиОле.Субконто(1).Наименование);
КонецЦикла;
ГлОлеБаза=0;
КонецПроцедуры
-------------------------------------------------------------------------------------------------------
А этот НЕТ :
-------------------------------------------------------------------------------------------------------
Процедура Сформировать()
перем БиоЛе ;
Если ГлОлеПодключитьБазу(Агентство.ПутьКБухБазе,Агентство.ПользовательВБухБазе,Агентство.ПарольВБухБазе,Агентство.КодФирмы)=0 Тогда
Возврат;
КонецЕсли;
ГлОлеБаза.EvalExpr("глБИ.ИспользоватьПланСчетов(ОсновнойПланСчетов())");
ГлОлеБаза.ExecuteBatch("глБИ.ИспользоватьСубконто(ВидыСубконто.Сотрудники)");
Если ГлОлеФирма <> 0 Тогда
ГлОлеБаза.глБи.ИспользоватьРазделительУчета(ГлОлеФирма);
КонецЕсли;
ГлОлеБаза.глБи.ВыполнитьЗапрос(НачМесяца(ДатаН),НачМесяца(ДатаН),"661",,,1,,1);
БиОле=ГлОлеБаза.глБи;
БиОле.ВыбратьСубконто(1);
Пока БиОле.ПолучитьСубконто(1)=1 Цикл
сообщить( БиОле.Субконто(1).Наименование);
КонецЦикла;
ГлОлеБаза=0;
КонецПроцедуры
-------------------------------------------------------------------------------------------------------
Они отличаются только счетом и видом субконто .....
При запуске под отладчиком второго фрагмента пишет :
--------
БиОле.ВыбратьСубконто(1) Данная операция допустима только в режиме запроса по аналитике !
-------------
Счет и субконто в плане счетов естественно присутствуют....

В какую сторону копать ?

Комментарии  

 
0 #2 aleksand 30.06.2013 17:00
Могу только предположить, что либо именно 1с-овские глюки, связанные конкретно с доступом через ОЛЕ - может там например параметры по умолчанию не действуют?

Иногда сталкивался с подобным, могу посоветовать попробовать:
1. в методе ИспользоватьСуб конто() вручную поставить параметр, что по субконто надо разворачивать
2. После ВыполнитьЗапрос () вставить вызовы:
БиОле.ВыбратьСчета();
БиОле.ПолучитьСчет();
А потом уже выборка по субконто... В принципе это не нужно но иногда я и с таким сталкивался, что без этого бух.запрос глючил...

если ни то ни другое не поможет - тогда хз )
 
 
0 #1 evgenij 22.06.2013 13:23
OLE - какашко. Попытайся этот запрос в самой базе исполнить...
 

You have no rights to post comments