• Mobile apps - просто как 2х2!

    Рост количества информации и ускорение темпов жизни все сильнее требует постоянного присутсвия в рабочей сети, в том числе и в пути. Именно поэтому такю большую популярность приобретают смартфоны, КПК и планшеты, представляющие собой мобильные компьютеры для доступа к рабочей и личной информации.

    Сегодня довольно сложно встретить человека без мобильного телефона или смартфона. Это уже не просто средство связи, но также и инструмент для работы, управления личными данными, общения в интернете, а также разного вида развлечений.

     
     
  • Аналитические данные

    Для иллюстрации разнообразных аналитических и научных данных довольно удобно использовать красивые диаграммы. Табличный редактор  от Microsoft Excel 2010 предлагает огромное количество как стандартных так и довольно редких диаграмм и позволяет создавать сложные комбинации из уже существующих шаблонов.

    Создать диаграмму в программе Excel 2010 довольно просто, так как, открывая эту программу, вам потребуется нажать всголишь пару кнопок. Остается всего лишь их заполнить таблицу с данными. Как же это сделать?Вы узнаете из статей нашего сайта.

     
  •  E-mail и рассылки

    Не секрет, что на сегодняшний день E-mail рассылка всё еще является эффективным рекламным средством, признанным во всей интернет среде, по соотношению цена качество. Охват массовой рассылки соизмерим, разве, что с рекламой по телефону

    Маркетинг путем рассылок по электронной почте позволяет создать необходимую программу регулярных рассылок для продвижения своего бренла и развития бизнеса в целом. Наконец, правильно построенный интернет маркетинг по почте может укрепить положительные взаимоотношения клиентов и организации.

     
  • Мобильные устройства

    Новости, обзоры и тесты портативной техники и мобильных устройств. Современные смартфоны, КПК и планшеты содержат в себе довольно взрослый функционал, аналогичный такому же у своих «старших братьев». Удаленное администрирование, браузеры с технологиями flash и java-script, синхронизация электронной почты, заметок, обмен различными файлами. Обо всем этом и не только подробнее на нашем сайте.

Вот незадача,Снова задача:(

Категория Помощь

Имеется форма,на ней 2 строки и кнопка.В начальную строку вводится слово,при нажатии на кнопку "Выполнить" в конечную строку выводятся символы(буквы) с простым индексом,как это осуществить? Имеется форма,на ней 2 строки и кнопка.В начальную строку вводится слово,при нажатии на кнопку "Выполнить" в конечную строку выводятся символы(буквы) с простым индексом,как это осуществить?

Комментарии  

 
0 #18 tatjana 28.07.2013 08:12
Никита Kael Пестин

Нужно вспомнить где такое встречается в типовых конфигурациях и посмотреть как там сделано.

Процедура СправочникСписо кКонтрагентыПри АктивизацииСтро ки(Элемент)

ТекКонтра = ЭлементыФормы.С правочникСписок Контрагенты.Тек ущиеДанные;
Если ТекКонтра <> Неопределено И НЕ ТекКонтра.ЭтоГр уппа Тогда
СправочникСписо кДоговорыКонтра гентов.Отбор.Вл аделец.Значение = ТекКонтра.Ссылк а;
СправочникСписо кДоговорыКонтра гентов.Отбор.Вл аделец.Использо вание = Истина;
Иначе
СправочникСписо кДоговорыКонтра гентов.Отбор.Вл аделец.Значение = Справочники.Кон трагенты.Пустая Ссылка();
СправочникСписо кДоговорыКонтра гентов.Отбор.Вл аделец.Использо вание = Истина;
КонецЕсли;

КонецПроцедуры
 
 
0 #17 mihail 25.07.2013 12:24
Там отбора нет, можно цикл чемнибуь заменить, например есть метод Найти() псмотри на него.
 
 
0 #16 mihail 15.07.2013 17:07
У тебя у таблиц тип значения таблица значений как понимаю? Или ссылка на табличную часть документа(или чегото), в людбом случае нужна табличная часть, для таблицы 2 тип делай ТаблицаЗначений , с теми колонками которые тебе нужны, при открытии заполняй ее теми данными которые у тебя в ТЧ, в ПриАктивизацииС троки Выгружай все из ТЧ, отбирай там только нужные, например.
Таблица2.Очистить();
Для Каждого Стр Из ТЧ Цикл
Если Стр.ДоговорКОнт рагента = Элемент.Контраг ент Тогда
Таблица2.Добавить....

Както вот так.
 
 
0 #15 nikita 12.07.2013 17:11
Добрый день.
Помогите пожалуйста начинающему с реализацией следующей вещи:
Есть форма. На ней две таблицы: Таблица1 и Таблица2.
В Таблицу1 выводятся элементы Справочника1, а в Таблицу2 элементы Справочника2.
Справчник1 является владельцем Справочника2 т.е. у каждого элемента Справочника2 в реквизите "Владелец" стоит ссылка на эл-т из Справочника1.
Что нужно? Чтобы при выборе эл-та из Таблицы1 в Таблице2 отображались только те эл-ты из Справочника2, для которых выбранный объект является владельцем.
Как составить код обработчика "ПриАктивизации Строки"?
 
 
0 #14 mihail 12.07.2013 02:19
Процедура КнопкаВыполнить Нажатие(Кнопка)
ПроверяемаяСтро ка = ИсходныеДанные;
ЧислоСимволов = СтрДлина(ПроверяемаяСтро ка)-1;
ПроверяемаяСтро ка = Прав(ПроверяемаяСтро ка, ЧислоСимволов);
параметр = 2;
//Убираем сразу первый символ, и начинаем со второго, т.к. 1 не простое.
//ну а дальше как я писал, только переменные переименовал.
СтрокаНаВыход = "";
Пока ЧислоСимволов <> 0 Цикл
ЧислоСимволов = ЧислоСимволов - 1;
Отказ = ПроверкаНаПрост оту(Параметр);
Если Не Отказ Тогда
Символ = Лев(ПроверяемаяСтро ка,1);
СтрокаНаВыход = СтрокаНаВыход Символ;
КонецЕсли;
ПроверяемаяСтро ка = Прав(ПроверяемаяСтро ка, ЧислоСимволов);
Параметр = параметр 1;
КонецЦикла;
ВыходныеДанные = СтрокаНаВыход;
КонецПроцедуры

Функция ПроверкаНаПрост оту(Проверяемое Число)
//Укороченый вариант той процедурки.
Вывод = Истина;
СамоЧисло = ПроверяемоеЧисл о-1;
Пока СамоЧисло > 1 Цикл
Если (ПроверяемоеЧис ло/СамоЧисло - Цел(ПроверяемоеЧис ло/СамоЧисло)) = 0 тогда
Вывод = Ложь;
КонецЕсли;
СамоЧисло = СамоЧисло - 1;
КонецЦикла;
Возврат Не Вывод;
КонецФункции
 
 
0 #13 magomed 06.07.2013 10:14
Михаил,может станете моим учителем?:)Ну очень хочу освоить вот это всё дело!
 
 
0 #12 magomed 03.07.2013 03:59
Процедура ВыполнитьНажатие(Элемент)
Вывод = Истина;
Попытка
ПроверяемоеЧисло = Число(ЧислоП);
Исключение
Сообщить("Невозможно преобразовать число " ЧислоП);
Возврат;
КонецПопытки;
СамоЧисло = ПроверяемоеЧисло-1;
Пока СамоЧисло > 1 Цикл
Если (ПроверяемоеЧис ло/СамоЧисло - Цел(ПроверяемоеЧис ло/СамоЧисло)) = 0 тогда
Сообщить("Число " Строка(Проверяе моеЧисло) " сложное");
Вывод = Ложь;
Прервать;
КонецЕсли;
СамоЧисло = СамоЧисло - 1;
КонецЦикла;
Если Вывод тогда
Сообщить("Число " Строка(Проверяе моеЧисло) " простое");
КонецЕсли;
КонецПроцедуры
 
 
0 #11 mihail 30.06.2013 20:14
ты предыдущую задачу сделал? Если да то кинь код. И сделаем)
 
 
0 #10 magomed 29.06.2013 09:11
что-то не получается у меня связать вот это всё:(
 
 
0 #9 mihail 22.06.2013 10:55
Так в условии не указано что строка ограниченной длины.
 
 
0 #8 artjom 21.06.2013 09:47
У него же строка ограниченной длины, зачем каждый раз выполнять одни и те же проверки, неэффективно.
 
 
0 #7 mihail 14.06.2013 06:08
Пожалуйста:) Весной с простыми числами случай был... В универ программу на сях надо было написать для проверки на простоту по какомуто алгоритмы. Прогрмму мне написали, но число 113 или тип того, она упорно говорила что составное, хотя множество других нормлаьно прошли. спасло условие что если 113 тогда простое... прокатило, но будьте осторожны с этими простыми числами:)
 
 
0 #6 mihail 11.06.2013 23:38
НА простоту ты проверять уже умеешь, вставь в модуль функцию проверяющую на простоту, если простое то возвращает Истина, иначе Ложь.
и примерно вот такой текст в процедуру выполнить или какая она там у тебя...

//Число символов в строке
ЧислоСимволов = СтрДлина(Строка );
//Параметр - номер символа в строке.
параметр = 1;
//Выходная строка.
СтрокаНаВыход = "";
//Пока идем по строке...
Пока ЧислоСимволов <> 0 Цикл
//Потом скажу зачем)
ЧислоСимволов = ЧислоСимволов - 1;
//Проверяем на простоту параметр.
Отказ = ПроверитьНаПрос тоту(Параметр);
//Если простое тогда добавляем к строке на выход.
Если Не Отказ Тогда
Символ = Лев(Строка,1);
СтрокаНаВыход = СтрокаНаВыход Символ;
КонецЕсли;
//Берем правые ЧислоНаВыжод символов, т.е. все кроме первого левого.
Строка = Прав(СтрокаНаВы ход, ЧислоСимволов);
//Увеличиваем параметр и идем дальше....
Параметр = параметр 1;
КонецЦикла;
//Ну и собственно пишем значение в поле ввода на форме.
ЭлементыФормы.В ыходноеПоле.Зна чение = СтрокаНаВыход;

Только от комментариев подчисть.
 
 
0 #5 artjom 08.06.2013 13:08
простые числа храним в массиве, строку перебираем в цикле, если индекс элемента 1 попадает в массиве, то добавляем на выход
 
 
0 #4 magomed 08.06.2013 11:18
напиример слово: автобус
1234567
в другую строку выводятся буквы которые в последовательно сти попадают на простое число: втбс
2357
при этом слово/предложен ие должно быть около 200символов...
 
 
0 #3 mihail 04.06.2013 20:58
что значит с простым индексом? Можно пример какойнибудь?:)
 
 
0 #2 magomed 04.06.2013 04:21
Я бы с удовольствием,н о .....:(
 
 
0 #1 artjom 01.06.2013 07:52
Домашнее задание нужно делать самостоятельно ))
 

You have no rights to post comments