• Mobile apps - просто как 2х2!

    Рост количества информации и ускорение темпов жизни все сильнее требует постоянного присутсвия в рабочей сети, в том числе и в пути. Именно поэтому такю большую популярность приобретают смартфоны, КПК и планшеты, представляющие собой мобильные компьютеры для доступа к рабочей и личной информации.

    Сегодня довольно сложно встретить человека без мобильного телефона или смартфона. Это уже не просто средство связи, но также и инструмент для работы, управления личными данными, общения в интернете, а также разного вида развлечений.

     
     
  • Аналитические данные

    Для иллюстрации разнообразных аналитических и научных данных довольно удобно использовать красивые диаграммы. Табличный редактор  от Microsoft Excel 2010 предлагает огромное количество как стандартных так и довольно редких диаграмм и позволяет создавать сложные комбинации из уже существующих шаблонов.

    Создать диаграмму в программе Excel 2010 довольно просто, так как, открывая эту программу, вам потребуется нажать всголишь пару кнопок. Остается всего лишь их заполнить таблицу с данными. Как же это сделать?Вы узнаете из статей нашего сайта.

     
  •  E-mail и рассылки

    Не секрет, что на сегодняшний день E-mail рассылка всё еще является эффективным рекламным средством, признанным во всей интернет среде, по соотношению цена качество. Охват массовой рассылки соизмерим, разве, что с рекламой по телефону

    Маркетинг путем рассылок по электронной почте позволяет создать необходимую программу регулярных рассылок для продвижения своего бренла и развития бизнеса в целом. Наконец, правильно построенный интернет маркетинг по почте может укрепить положительные взаимоотношения клиентов и организации.

     
  • Мобильные устройства

    Новости, обзоры и тесты портативной техники и мобильных устройств. Современные смартфоны, КПК и планшеты содержат в себе довольно взрослый функционал, аналогичный такому же у своих «старших братьев». Удаленное администрирование, браузеры с технологиями flash и java-script, синхронизация электронной почты, заметок, обмен различными файлами. Обо всем этом и не только подробнее на нашем сайте.

Никак не заработает обработка, может кто поможет??????

Категория Помощь

начала писать обработку, которая на дебетовый отрицательный остаток создает документ по реализации на такую же сумму, но споткнулась на том, что у клиента не проставлены основные договора контрагентов, то есть надо прописать еще одну обработку или функцией прописать, никак не сооображу куда ее впихнуть....Обработка по созданию документа вот: Процедура КнопкаВыполнитьНажатие(Кнопка) Запрос = Новый Запрос; Запрос.Текст = "ВЫБРАТЬ | ХозрасчетныйОстатки.Счет КАК Счет, | ХозрасчетныйОстатки.Субконто1 КАК Контрагент, | ХозрасчетныйОстатки.СуммаОстатокДт КАК СуммаОстаток |ИЗ | РегистрБухгалтерии.Хозрасчетный.Остатки(&НаДату, Счет В ИЕРАРХИИ (&Счет), , Организация = &Организация) КАК ХозрасчетныйОстатки" ; Запрос.УстановитьПараметр("НаДату",КонецМесяца(ЭлементыФормы.ТекущаяДата.Значение)); Запрос. начала писать обработку, которая на дебетовый отрицательный остаток создает документ по реализации на такую же сумму, но споткнулась на том, что у клиента не проставлены основные договора контрагентов, то есть надо прописать еще одну обработку или функцией прописать, никак не сооображу куда ее впихнуть....

Обработка по созданию документа вот:
Процедура КнопкаВыполнитьНажатие(Кнопка)

Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
| ХозрасчетныйОстатки.Счет КАК Счет,
| ХозрасчетныйОстатки.Субконто1 КАК Контрагент,
| ХозрасчетныйОстатки.СуммаОстатокДт КАК СуммаОстаток
|ИЗ
| РегистрБухгалтерии.Хозрасчетный.Остатки(&НаДату, Счет В ИЕРАРХИИ (&Счет), , Организация = &Организация) КАК ХозрасчетныйОстатки"
;

Запрос.УстановитьПараметр("НаДату",КонецМесяца(ЭлементыФормы.ТекущаяДата.Значение));
Запрос.УстановитьПараметр("Организация", ЭлементыФормы.Организация.Значение);
Запрос.УстановитьПараметр("Счет",ЭлементыФормы.Счет.Значение);
Результат = Запрос.Выполнить().Выбрать();
Пока Результат.Следующий() Цикл
Сообщить(Результат.Счет);
Сообщить(Результат.Контрагент);
Сообщить(Результат.СуммаОстаток);
Реализация = Документы.РеализацияТоваровУслуг.СоздатьДокумент();
Реализация.ОтражатьВНалоговомУчете = Истина;
Реализация.ВидОперации = Перечисления.ВидыОперацийРеализацияТоваров.ПродажаКомиссия;
Реализация.Дата = КонецМесяца(ЭлементыФормы.ТекущаяДата.Значение);
Реализация.Организация = ЭлементыФормы.Организация.Значение;
Реализация.Контрагент = Результат.Контрагент;
Реализация.ДоговорКонтрагента = Результат.Контрагент.ОсновнойДоговорКонтрагента;
Реализация.ВалютаДокумента = Справочники.Валюты.НайтиПоКоду("810");
Реализация.СчетУчетаРасчетовСКонтрагентом = ПланыСчетов.Хозрасчетный.НайтиПоКоду("62.01");
Реализация.СчетУчетаРасчетовПоАвансам = ПланыСчетов.Хозрасчетный.НайтиПоКоду("62.02");

Реализация.Комментарий = "Создан с помощью внешней обработки";

ТекСтрока = Реализация.Услуги.Добавить();
ТекСтрока.Номенклатура = Справочники.Номенклатура.НайтиПоКоду("000000216");
ТекСтрока.Содержание = "Диспетчерские услуги";
ТекСтрока.Количество = 1;
ТекСтрока.Цена = Результат.СуммаОстаток*(-1);
ТекСтрока.Сумма = ТекСтрока.Количество * ТекСтрока.Цена;
ТекСтрока.СчетДоходовБУ = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.01.1");
ТекСтрока.СчетРасходовБУ = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.02.1");
Реализация.Записать(РежимЗаписиДокумента.Проведение);
КонецЦикла;

КонецПроцедуры

А функция должна выглядеть как то так(до конца не могу додуматься):
Функция ПолучитьДоговоор(Контрагент)
ОсновнойДоговор = Контрагент.Основнойдоговор;
Если ЗначениеЗаполнено(ОсновнойДоговор) Тогда
Если ОсновнойДоговор.ВидДоговора = СПокупателем Тогда
Возврат ОсновнойДоговор;
КонецЕсли;
КонецЕсли;
ЗапросОстальныхДоговоров = Новый Запрос;
Запрос.Текст = Выбрать Ссылка Из Справочники.Договоры Где Владелец = Контрагент;
//Здесь обходишь результат запроса и если находишь подходящий договор, то возвращаешь его

//Если возврат не произошел, то создаем новый договор
Договор = Справочники.ДоговораКонтрагентов.СоздатьЭлемент();
Договор.Владелец = Контрагент;
Договор.Виддоговора = СПокупателем;
Договор.Записать();
Возврат Договор;
КонецФункции

Помогите пожалуйста куда эту функцию впихнуть и что в ней исправить?

Комментарии  

 
0 #2 denis 28.07.2013 09:07
Так и писать : Реализация.Дого ворКонтрагента = ОсновнойДоговор (Контрагент)
и функция какая-то такая :
Функция ОсновнойДоговор (КонтрагентСсыл ка)
ВозвращаемыйОсн овнойДоговор= Неопределено;
Если ЗначениеЗаполне но(КонтрагентСс ылка.ОсновнойДо говорКонтрагент а) Тогда
ВозвращаемыйОсн овнойДоговор= КонтрагентСсылк а.ОсновнойДогов орКонтрагента;
Иначе
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ДоговорыКонтраг ентов.Ссылка
|ИЗ
| Справочник.Дого ворыКонтрагенто в КАК ДоговорыКонтраг ентов
|ГДЕ
| ДоговорыКонтраг ентов.Владелец = &Владелец";
Запрос.Установи тьПараметр("Вла делец", КонтрагентСсылк а);
Результат = Запрос.Выполнит ь();
ВыборкаДетальны еЗаписи = Результат.Выбра ть();
Пока ВыборкаДетальны еЗаписи.Следующий() Цикл
ВозвращаемыйОсн овнойДоговор=ВыборкаДетальны еЗаписи.Ссылка;
// здесь или в тексте запроса надо выбрать как-то один договор
КонецЦикла;
Если ВозвращаемыйОсн овнойДоговор= Неопределено Тогда
ОсновнойДоговор Контрагента = Справочники.ДоговорыКонтраг ентов.СоздатьЭлемент();
ОсновнойДоговор Контрагента.Наименование = "Основной договор";
ОсновнойДоговор Контрагента.ВедениеВзаиморасчетов =Перечисления.В едениеВзаиморас четовПоДоговора м.ПоДоговоруВЦе лом;// или ПоРасчетнымДоку ментам
ОсновнойДоговор Контрагента.ВалютаВзаиморасчетов = Константы.Валют аРегламентирова нногоУчета.Полу чить();
ОсновнойДоговор Контрагента.Организация =глЗначениеПере менной("Основна яОрганизация");
ОсновнойДоговор Контрагента.Владелец = КонтрагентСсылк а;
ОсновнойДоговор Контрагента.ВидДоговора =Перечисления.В идыДоговоровКон трагентов.СПоку пателем; //или с поставщиком
ОсновнойДоговор Контрагента.Записать();
ВозвращаемыйОсн овнойДоговор=ОсновнойДоговор Контрагента.Ссылка;
КонецЕсли;
КонтрагентОбъек т=КонтрагентСсы лка.ПолучитьОбъ ект();
КонтрагентОбъект.ОсновнойДоговор Контрагента=ОсновнойДоговор Контрагента.Ссылка;
КонтрагентОбъек т.Записать();
КонецЕсли;
Возврат ВозвращаемыйОсн овнойДоговор;
КонецФункции
 
 
0 #1 elena 28.07.2013 09:07
Конфа БП 1.6 типовая, последний релиз
 

You have no rights to post comments