• Mobile apps - просто как 2х2!

    Рост количества информации и ускорение темпов жизни все сильнее требует постоянного присутсвия в рабочей сети, в том числе и в пути. Именно поэтому такю большую популярность приобретают смартфоны, КПК и планшеты, представляющие собой мобильные компьютеры для доступа к рабочей и личной информации.

    Сегодня довольно сложно встретить человека без мобильного телефона или смартфона. Это уже не просто средство связи, но также и инструмент для работы, управления личными данными, общения в интернете, а также разного вида развлечений.

     
     
  • Аналитические данные

    Для иллюстрации разнообразных аналитических и научных данных довольно удобно использовать красивые диаграммы. Табличный редактор  от Microsoft Excel 2010 предлагает огромное количество как стандартных так и довольно редких диаграмм и позволяет создавать сложные комбинации из уже существующих шаблонов.

    Создать диаграмму в программе Excel 2010 довольно просто, так как, открывая эту программу, вам потребуется нажать всголишь пару кнопок. Остается всего лишь их заполнить таблицу с данными. Как же это сделать?Вы узнаете из статей нашего сайта.

     
  •  E-mail и рассылки

    Не секрет, что на сегодняшний день E-mail рассылка всё еще является эффективным рекламным средством, признанным во всей интернет среде, по соотношению цена качество. Охват массовой рассылки соизмерим, разве, что с рекламой по телефону

    Маркетинг путем рассылок по электронной почте позволяет создать необходимую программу регулярных рассылок для продвижения своего бренла и развития бизнеса в целом. Наконец, правильно построенный интернет маркетинг по почте может укрепить положительные взаимоотношения клиентов и организации.

     
  • Мобильные устройства

    Новости, обзоры и тесты портативной техники и мобильных устройств. Современные смартфоны, КПК и планшеты содержат в себе довольно взрослый функционал, аналогичный такому же у своих «старших братьев». Удаленное администрирование, браузеры с технологиями flash и java-script, синхронизация электронной почты, заметок, обмен различными файлами. Обо всем этом и не только подробнее на нашем сайте.

Удалить строку

Категория Помощь

Ребят помогите, плиз!1С 8.1. Как программно удалить строку из табличной части документа, в которой пустое поле цена. Ребят помогите, плиз!
1С 8.1. Как программно удалить строку из табличной части документа, в которой пустое поле цена.

Комментарии  

 
0 #17 aleksej 25.07.2013 19:05
2Евгения Пуркарьян : молодца. :)
 
 
0 #16 evgenija 24.07.2013 11:14
Я решила проблему, выгрузила информационную базу и загрузила в чистую, и все заработало без админа)
 
 
0 #15 aleksej 20.07.2013 12:00
2Татьяна Пухова : работать пока я, ибо не знаю, кто будет высыпаться :)
 
 
0 #14 tatjana 17.07.2013 22:03
to: Евгения Алексеевна Пуркарьян

Одмина трясти
 
 
0 #13 evgenija 16.07.2013 02:35
Ребят, вы лучше подскажите, чего делать, когда при попытке обновления базы выскакивает ошибка - само окно подписано Microsoft Visual C бла, бла, бла
Runtime Error
This application has reguested...
 
 
0 #12 evgenija 07.07.2013 01:06
я просто поставила условие в цикле, где создается эта таблица по кнопке заполнить(докум ент "установка цен номенклатуры") если Цена 0 то удалить на фик эту строчку)
 
 
0 #11 andrej 05.07.2013 12:54
Я бы через НайтиСтроки() собрал массив ссылок на строки нулевыми ценами, а затем все их обходом по массиву удалил.
 
 
0 #10 tatjana 05.07.2013 11:52
Высыпаться... А кто работать будет?
 
 
0 #9 aleksej 01.07.2013 16:59
2Татьяна Пухова : не считаю ВТ извращением. Весьма полезная штука ;). Правда, если ссылки нет, в типовых конфах предлагают документ попросту записать.
Запрос - не главное... Главное - высыпаться =)
 
 
0 #8 tatjana 26.06.2013 14:08
Алексей [Чёрный_КОТ] Власкин

А если объект (которого табличная часть) не записан... то можно извратиться через временную таблицу... главное чтобы был запрос :)

И ни в коем случае не применять GOTO :)
 
 
0 #7 andr-j 22.06.2013 20:35
"А семёрочными методами при наличии эффективных восьмёрочных пользоваться не комильфо." 1
 
 
0 #6 aleksej 22.06.2013 17:32
Вариантов тысяча... Быстрее всего запросом отобрать все строки, в которых цена не пустая, затем очищаем табличную часть и загружаем в неё результат запроса...

А семёрочными методами при наличии эффективных восьмёрочных пользоваться не комильфо.
 
 
0 #5 tatjana 20.06.2013 02:40
Я быстро печатаю :) Не проблема
 
 
0 #4 dmitriy 16.06.2013 08:24
зачем же такой пост большой?:)

да, признаюсь в запаре был, ЗАТУПИЛ:)
 
 
0 #3 tatjana 15.06.2013 14:32
Dmitriy Zyablikov

:))) ну да, конечно больше, т.е.

сч = 0;
Пока ТабЧасть.Количе ство() > сч Цикл
Если ТабЧасть[сч].Це на = 0 Тогда
ТабЧасть.Удалить(сч);
Иначе
сч = сч 1;
КонецЕсли;
КонецЦикла;

Мне Ваши примерчики кстати тоже не понравились :)

В процессе удаления строк из таблицы есть фишка: когда удаляется строка, то индексы сдвигаются, поэтому нельзя использовать "Для каждого" (это по поводу примера №2)

А если использовать индексы, то или удаляем или увеличиваем счётчик.

Проще всего представить себе таблицу, в которой все строки придётся удалить...
Пример №1: удалили строку с индексом 0, она удалилась и индекс 0 стал у бывшей второй строки. Но мы уже индекс увеличили и проверяем строку с индексом 1, соответственно в таблице удалятся не все строки, а через одну.
 
 
+1 #2 dmitriy 13.06.2013 19:43
Татьяна Пухова, с таким кодом Вы в Цикл никогда не попадете:)

Можно так:
сч = 0;
Пока сч < ТЧ.Количество() Цикл
Если ТЧ[сч].Цена = 0 Тогда
ТЧ.Удалить(сч);
КонецЕсли;
сч = сч 1;
КонецЦикла;

Или так:

Для Каждого Строка Из ТЧ Цикл
Инд = ТЧ.Индекс(Строк а);
Если ТЧ[Инд].Цена = 0 Тогда
ТЧ.Удалить(Инд) ;
КонецЕсли;
КонецЦикла;
 
 
+1 #1 tatjana 12.06.2013 14:50
Классика :) "Для каждого" использовать нельзя.

сч = 0;
Пока ТабЧасть.Количе ство() < сч Цикл
Если ТабЧасть[сч].Це на = 0 Тогда
ТабЧасть.Удалит ь(сч);
Иначе
сч = сч 1;
КонецЕсли;
КонецЦикла;

(редактор зараза сам убирает синтаксический отступ)
 

You have no rights to post comments