• Mobile apps - просто как 2х2!

    Рост количества информации и ускорение темпов жизни все сильнее требует постоянного присутсвия в рабочей сети, в том числе и в пути. Именно поэтому такю большую популярность приобретают смартфоны, КПК и планшеты, представляющие собой мобильные компьютеры для доступа к рабочей и личной информации.

    Сегодня довольно сложно встретить человека без мобильного телефона или смартфона. Это уже не просто средство связи, но также и инструмент для работы, управления личными данными, общения в интернете, а также разного вида развлечений.

     
     
  • Аналитические данные

    Для иллюстрации разнообразных аналитических и научных данных довольно удобно использовать красивые диаграммы. Табличный редактор  от Microsoft Excel 2010 предлагает огромное количество как стандартных так и довольно редких диаграмм и позволяет создавать сложные комбинации из уже существующих шаблонов.

    Создать диаграмму в программе Excel 2010 довольно просто, так как, открывая эту программу, вам потребуется нажать всголишь пару кнопок. Остается всего лишь их заполнить таблицу с данными. Как же это сделать?Вы узнаете из статей нашего сайта.

     
  •  E-mail и рассылки

    Не секрет, что на сегодняшний день E-mail рассылка всё еще является эффективным рекламным средством, признанным во всей интернет среде, по соотношению цена качество. Охват массовой рассылки соизмерим, разве, что с рекламой по телефону

    Маркетинг путем рассылок по электронной почте позволяет создать необходимую программу регулярных рассылок для продвижения своего бренла и развития бизнеса в целом. Наконец, правильно построенный интернет маркетинг по почте может укрепить положительные взаимоотношения клиентов и организации.

     
  • Мобильные устройства

    Новости, обзоры и тесты портативной техники и мобильных устройств. Современные смартфоны, КПК и планшеты содержат в себе довольно взрослый функционал, аналогичный такому же у своих «старших братьев». Удаленное администрирование, браузеры с технологиями flash и java-script, синхронизация электронной почты, заметок, обмен различными файлами. Обо всем этом и не только подробнее на нашем сайте.

Обороты между счетами в 1С 8

Категория Помощь

Добрый вечер! Подскажите, кто знает:Мне нужны обороты между двумя конкретными счетами за конкретный период. Но у меня не получается выбрать даже просто обороты счета. Делаю следующим образом, не могу понять в чем ошибка, то ли в запросе, то ли в обращении к результатам запроса: |ВЫБРАТЬ | ХозрасчетныйОбороты.СуммаОборотДт КАК ОбДт, | ХозрасчетныйОбороты.СуммаОборотКт КАК ОбКт |ИЗ | РегистрБухгалтерии.Хозрасчетный.Обороты(&НачПериода,&КонПериода, |Период, Счет=&Счет,,,,) |КАК ХозрасчетныйОбороты "; Запрос.УстановитьПараметр("НачПериода",'20100101'); Запрос.УстановитьПараметр("КонПериода",'20101201'); Запрос.УстановитьПараметр("Счет",ПланыСчетов.Хозрасчетный.ВыручкаЕНВД);//счет 90.01.1 Результат=Запрос.Выполнить(); Выборка = Результат.Выбрать(); Сообщить("Дт " Выборка.ОбДт " Кт " Выборка.Об Добрый вечер! Подскажите, кто знает:
Мне нужны обороты между двумя конкретными счетами за конкретный период. Но у меня не получается выбрать даже просто обороты счета. Делаю следующим образом, не могу понять в чем ошибка, то ли в запросе, то ли в обращении к результатам запроса:

|ВЫБРАТЬ
| ХозрасчетныйОбороты.СуммаОборотДт КАК ОбДт,
| ХозрасчетныйОбороты.СуммаОборотКт КАК ОбКт
|ИЗ
| РегистрБухгалтерии.Хозрасчетный.Обороты(&НачПериода,&КонПериода,
|Период, Счет=&Счет,,,,)
|КАК ХозрасчетныйОбороты ";

Запрос.УстановитьПараметр("НачПериода",'20100101');
Запрос.УстановитьПараметр("КонПериода",'20101201');
Запрос.УстановитьПараметр("Счет",ПланыСчетов.Хозрасчетный.ВыручкаЕНВД);//счет 90.01.1
Результат=Запрос.Выполнить();
Выборка = Результат.Выбрать();
Сообщить("Дт " Выборка.ОбДт " Кт " Выборка.ОбКт);

пробовала это в 8.1 и 8.2. В 8.2 хотя бы нули написало, а в 8.1 ничего, и при отладке пишет что значение неопределено.

Комментарии  

 
0 #7 olja 28.07.2013 08:53
Разобралсь в чем дело! Была не указана организация! Теперь все запросы работают! :)
 
 
0 #6 mihail 27.07.2013 14:41
ты только сначала по оборотке посмотри, чтобы обороты действительно были.
Незачто
 
 
0 #5 mihail 16.07.2013 03:31
Процедура КактоВотТакЭтоВ сеРаботает() Экспорт
//{{КОНСТРУКТОР _ЗАПРОСА_С_ОБРА БОТКОЙ_РЕЗУЛЬТА ТА
// Данный фрагмент построен конструктором.
// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ХозрасчетныйОбо ротыДтКт.СуммаО борот
|ИЗ
//| РегистрБухгалте рии.Хозрасчетны й.ОборотыДтКт(& НачалоПериода, &КонецПериода, , СчетДт = ЗНАЧЕНИЕ(ПланСч етов.Хозрасчетн ый.ТоварыНаСкла дах), , СчетКт = ЗНАЧЕНИЕ(ПланСч етов.Хозрасчетн ый.РАсчетыСПост авщиками), , Организация = &Организация) КАК ХозрасчетныйОбо ротыДтКт";
| РегистрБухгалте рии.Хозрасчетны й.ОборотыДтКт(& НачалоПериода, &КонецПериода, , СчетДт = ЗНАЧЕНИЕ(ПланСч етов.Хозрасчетн ый.ТоварыНаСкла дах), , СчетКт = ЗНАЧЕНИЕ(ПланСч етов.Хозрасчетн ый.РАсчетыСПост авщиками), ,) КАК ХозрасчетныйОбо ротыДтКт";
Запрос.Установи тьПараметр("Кон ецПериода", ДатаОкончания);
Запрос.Установи тьПараметр("Нач алоПериода", ДатаНачала);
//Запрос.Устано витьПараметр("О рганизация", Организация);

Результат = Запрос.Выполнит ь();

ВыборкаДетальны еЗаписи = Результат.Выбра ть();

Пока ВыборкаДетальны еЗаписи.Следующий() Цикл
Сообщить("Тадам ! " ВыборкаДетальны еЗаписи.СуммаОборот);
КонецЦикла;

КонецПроцедуры

Комплексная автоматизация 1.1. в бухе 1.6 точно должно работать, в 2.0 не факт.
 
 
0 #4 olja 14.07.2013 07:41
1.6 и в бюджетной тоже пробовала - аналогично
 
 
0 #3 olja 08.07.2013 01:40
я оба варианта пробовала - результат тот же :(
 
 
0 #2 mihail 04.07.2013 08:29
А черт, у тебя же обхода нет, Твой запрос тоже работает кстати...
но надо строчку добавить.
Результат=Запрос.Выполнить();
Выборка = Результат.Выбрать();
Выборка.Следующ ий();//_Вот она новая строчка_!
Сообщить("Дт " Выборка.ОбДт " Кт " Выборка.ОбКт);

Или...

Результат=Запрос.Выполнить();
Выборка = Результат.Выбрать();
Пока Выборка.Следующ ий() Цикл
Сообщить("Дт " Выборка.ОбДт " Кт " Выборка.ОбКт);
КонецЦикла;//Эт уже если не 1 запись.

Для написания запросов советую пользоваться консолькой запросов, гораздо удобней чем отладчик перезапускать;)
 
 
0 #1 mihail 03.07.2013 16:29
В запросе Оль... В запросе...

ВЫБРАТЬ
СуммаОборот
ИЗ
РегистрБухгалте рии.Хозрасчетны й.ОборотыДтКт(& НачалоПериода, &КонецПериода, Регистратор, СчетДт = ЗНАЧЕНИЕ(ПланСч етов.Хозрасчетн ый.ТоварыНаСкла дах), , СчетКт = ЗНАЧЕНИЕ(ПланСч етов.Хозрасчетн ый.РАсчетыСПост авщиками), , Организация = &Организация)
 

You have no rights to post comments