Прошу помощи в обучении

Категория Помощь

Изучаю 1с по книге Радченко. на 13 занятии дошел до отчетов.Отчет не выводит выручку. не могу понять почемуневерно Левое соединение выполнено? Изучаю 1с по книге Радченко. на 13 занятии дошел до отчетов.
Отчет не выводит выручку.
не могу понять почему
неверно Левое соединение выполнено?

Комментарии  

 
0 #65 aleksej 18.06.2013 11:53
Ошибка вроде в том, что ты считываешь тот же файл обмена, который сам формируешь (MessageЦБ_Фил. xml). Тогда, как по логике, следует считывать изменения из файла с изменениями, который формирует база филиала (MessageФил_ЦБ.xml).

Попробуй заменить:
ИмяФайла=Каталог ?(Прав(Каталог, 1)="\","","\") "Message" СокрЛП(ПланыОбмена.
Филиалы.ЭтотУзел().Код) "_" СокрЛП(Ссылка.К од) ".xml";

на:
ИмяФайла = Каталог ?(Прав(Каталог, 1) = "\", "", "\") "Message" СокрЛП(Ссылка.К од) "_" СокрЛП(ПланыОбм ена.Филиалы.Это тУзел().Код) ".xml";

На будущее:
1. У Радченко есть сопроводительны е материалы с базами-решениям и. Их можно использовать для поиска ошибок (Конфигурация - Сравнить конфигурации).
2. Советую использовать красивое форматирование кода (советую книгу Гудлифа Питера "Ремесло програмиста" по этому поводу). В хорошо отформатированн ом и структурированн ом коде ошибки сами в глаза бросаются.
Цитировать
 
 
0 #64 nikolaj 17.06.2013 15:04
Alexander, Здравствуйте! прошу помощи или совета!
В подсистеме предприятие не работает команда "обмен данными", выбрасывает ошибку:
{ПланОбмена.Филиалы.МодульОбъекта(83)}: Ошибка при вызове метода контекста (НачатьЧтение)
ЧтениеСообщения.НачатьЧтение(ЧтениеXML);
по причине:
Неизвестный получатель

Я полагаю, что ошибка находится в процедуре "ПрочитатьСообщ ениеСИзменениям и (План обмена "Филиалы" ~~~> модуль объекта), так как при вычислении выражения в переменной ЧтениеСообщения не выполняется метод НачатьЧтение
Цитировать
 
 
0 #63 nikolaj 17.06.2013 06:26
Alexander, спс) уже 9-й час сижу над 1С - походу пора идти спать, ничего не соображаю((
Цитировать
 
 
0 #62 aleksand 16.06.2013 21:51
Николай, Истина или Ложь возвращается при проверке на равенство Прав(Каталог,1) ="\" (равен ли первый правый (из перем Каталог) символ "\")
Цитировать
 
 
0 #61 aleksand 16.06.2013 14:45
Николай,
Синтаксис:
Прав(<Строка>, <ЧислоСимволов> )

Параметры:
<Строка> (обязательный)
Тип: Строка.
Исходная строка.

<ЧислоСимволов> (обязательный)
Тип: Число.
Количество выбираемых символов.

ВОЗВРАЩАЕМОЕ ЗНАЧЕНИЕ:
Тип: Строка.
Строка выбранных символов.

Описание:
Выбирает последние справа символы строки.
Цитировать
 
 
0 #60 nikolaj 14.06.2013 11:12
Alexander, все равно не доходит до меня - почему вот это параметр Прав(Каталог,1) имеет тип "Строка" а не Булево?
Цитировать
 
 
0 #59 aleksand 13.06.2013 02:16
Николай, я тебе подскажу волшебное сочетание клавиш: делаешь дабл клик на интересуемом методе/свойстве /функции (напр. "Прав"), а затем нажимаешь Ctrl F1 и творится волшебство =)
?(Прав(Каталог,1)="\","","\") - расшифровка Если первый справа символ переменной Каталог = "\" тогда возвращаем "" Иначе возвращаем "\"
Цитировать
 
 
0 #58 nikolaj 11.06.2013 08:56
Alexander, Здравствуйте! Объясните чайнику: что означает следующее выражение?

ИмяФайла=Каталог ?(Прав(Каталог, 1)="\","","\") "Message" СокрЛП(ПланыОбмена.
Филиалы.ЭтотУзел().Код "_" СокрЛП(Ссылка.К од) ".xml";

вопросительный знак означает что-то вроде if else, я так понимаю~~~~>

?(true/false; exp1; exp2)
Типа если истина, то выполняется первое выражение иначе второе...

ну да - так в синтаксис-помощ нике и написано

а в этом выражении где это всё? Прав - имеет тип "Строка"
Цитировать
 
 
0 #57 aleksand 10.06.2013 13:05
Nikolay, а без них и без знания предметной области в 1С никуда
Цитировать
 
 
0 #56 nikolaj 10.06.2013 03:24
Александр, да я просто не владею пользовательски ми знаниями - никогда не работал в 1С
Цитировать
 
 
0 #55 aleksand 10.06.2013 03:05
Nikolay, бывает, все варианты переберешь, а банальную мелочь не заметишь =)
Цитировать
 
 
0 #54 aleksand 09.06.2013 14:00
Николай, все у тебя нормально, у тебя просто настройка периода отображения на этом регистре стоит "последние 7 дней" вот и движения не показываются
Цитировать
 
 
0 #53 nikolaj 09.06.2013 06:06
Alexander, Здравствуйте! Прошу еще раз вашей помощи: при выполнении урока №21 я наткнулся на такую неприятность - при создании документа
"ВвводНачальныхОстатковНоменклатуры" и сохранении его, я заметил, что отсутствует Движение по регистру ОстаткиМатериалов.
Я как-то раньше не обратил внимание на этот регистр и подозреваю, что допустил ошибку где-то ранее (потому как этот регистр работает только
с новосозданными документами типа ПриходнаяНаклад ная), а вот где ошибка - не могу найти. Подскажите, пожалуйста - в какую сторону копать?
Цитировать
 
 
0 #52 nikolaj 08.06.2013 21:45
Александр, да! я тоже только что заметил) и в книге нашел (Стр602 первый абзац)
Цитировать
 
 
0 #51 aleksand 08.06.2013 09:39
Николай, ну так там созданы элементы формы РезультатыПоиск а и ТекущаяПозиция, а у тебя их нет
Цитировать
 
 
0 #50 nikolaj 04.06.2013 00:00
Alexander, нашел на кампе базу с 20-ю уроками - там такой же модуль, НО ОН РАБОТАЕТ! короче ладно - потом разберусь
Цитировать
 
 
0 #49 nikolaj 03.06.2013 16:21
Александр, да отож - не знаю уже что и делать(((
Цитировать
 
 
0 #48 aleksand 02.06.2013 18:03
Nikolay, как в описании, только что за РезультатыПоиск а и ТекущаяПозиция в процедуру не передается
Цитировать
 
 
0 #47 nikolaj 02.06.2013 14:54
Александр, как корявый? вроде ж все так как в описании, разве нет???
Цитировать
 
 
0 #46 nikolaj 02.06.2013 09:54
Александр, цитирую описание этой процедуры:
"Сначала в этой процедуре мы создаем список поиска, используя метод СоздатьСписок() объекта ПолнотекстовыйП оиск, и сохраняем его в переменной СписокПоиска.
Затем устанавливаем поисковое выражение, введенное пользователем, в качестве строки поиска для полнотекстового поиска. Затем в зависимости от направления поиска выполняем метод ПерваяЧасть(), ПредыдущаяЧасть () или СледующаяЧасть( ), который собственно запускает полнотекстовый поиск и возвращает соответственно первую порцию результатов, либо предыдущую, либо следующую порцию в зависимости от текущей позиции поиска. По умолчанию порция содержит 20 элементов.
Затем мы очищаем список значений РезультатыПоиск а и заполняем его нвйденными элементами.
Затем получаем результат полнотекстового поиска в виде HTML-текста и сохраняем этот текст в реквизите РезультатПоиска , имеющим тип HTML-документа.

и т.д.
Цитировать
 
 
0 #45 nikolaj 01.06.2013 16:29
Александр, сам не могу понять - в книге так написано, не могу объяснить до сих пор
Цитировать
 
 
0 #44 nikolaj 01.06.2013 02:39
Alexander,

то есть изменить на " &НаКлиенте" ? -пробовал - не помогает, тут в чем-то другом причина

&НаСервере
Процедура ИскатьСервер(На правление) Экспорт
СписокПоиска=По лнотекстовыйПои ск.СоздатьСписо к();
СписокПоиска.Ст рокаПоиска=Поис ковоеВыражение;

Если Направление=0 Тогда
СписокПоиска.Пе рваяЧасть();

ИначеЕсли Направление=-1 Тогда
СписокПоиска.Пр едыдущаяЧасть(Т екущаяПозиция);

ИначеЕсли Направление=1 Тогда
СписокПоиска.Сл едующаяЧасть(Те кущаяПозиция);
КонецЕсли;

РезультатыПоиск а.Очистить();
Для каждого Результат Из СписокПоиска Цикл
РезультатыПоиск а.Добавить(Резу льтат.Значение) ;
КонецЦикла;

РезультатПоиска =СписокПоиска.П олучитьОтображе ние
(ВидОтображения Полнотекстового Поиска.HTMLТекс т);
ТекущаяПозиция= СписокПоиска.На чальнаяПозиция( );
ПолноеКоличеств о=СписокПоиска. ПолноеКоличеств о();

Если СписокПоиска.Ко личество()<>0 Тогда
СообщениеОРезул ьтате= "Показаны " Строка(ТекущаяП озиция 1) " - "
Строка(ТекущаяП озиция СписокПоиска.Ко личество()) "из"
Строка(ПолноеКо личество);
Элементы.Следую щаяПорция.Досту пность = (ПолноеКоличест во-ТекущаяПозиц ия)
>СписокПоиска.К оличество();
Элементы.Предыд ущаяПорция.Дост упность=(Текуща яПозиция>0);
Иначе
СообщениеОРезул ьтате="Не найдено!";
Элементы.Следую щаяПорция.Досту пность=Ложь;
Элементы.Предыд ущаяПорция.Дост упность=Ложь;
КонецЕсли;



КонецПроцедуры
Цитировать
 
 
0 #43 nikolaj 31.05.2013 09:11
Александр, хм,в книге всё так и написано,цитирую:

"Итак, на закладке "Реквизиты" создадим реквизит ПоисковоеВыраже ние и перетащим его в окно элементов формы" и на рисунке 19.8 иллюстрация того как я и сделал
Цитировать
 
 
0 #42 aleksand 30.05.2013 21:23
Nikolay, да, если хочешь к ним обращаться именно с сервера, внимательно посмотри что в книге
Цитировать
 
 
0 #41 nikolaj 27.05.2013 17:11
Alexander, то есть надо создать реквизиты не только в форме отчета, но и в самом отчете?
Цитировать
 
 
0 #40 aleksand 27.05.2013 15:07
Николай, ну правильно у тебя все элементы формы и реквизиты формы, а ты пытаешься к ним обратиться на сервере, тебе либо обращаться к ним нужно на Клиенте либо завести их как реквизиты объекта и затем вывести на форму
Цитировать
 
 
0 #39 nikolaj 24.05.2013 13:12
Alexander, Здравствуйте еще раз! у меня снова халэпа((
в 19 уроке написал всё как в листингах - уже 4 часа ищу ошибки, кое-что нашел. и главное не понимаю как искать причину ошибок. может вы подскажете?

выдаёт следующии

{Отчет.ПоискДанных.Форма.ФормаОтчета.Форма(36,33)}: Переменная не определена (ТекущаяПозиция )
СписокПоиска.ПредыдущаяЧасть(<--?--»ТекущаяПозиция); (Проверка: Сервер)
{Отчет.ПоискДанных.Форма.ФормаОтчета.Форма(39,36)}: Переменная не определена (ТекущаяПозиция )
СписокПоиска.Сл едующаяЧасть(<- -?--»ТекущаяПоз иция); (Проверка: Сервер)
{Отчет.ПоискДанных.Форма.ФормаОтчета.Форма(42,3)}: Переменная не определена (РезультатыПоиска)
<--?--»РезультатыПоиска.Очистить(); (Проверка: Сервер)
{Отчет.ПоискДанных.Форма.ФормаОтчета.Форма(44,4)}: Переменная не определена (РезультатыПоиска)
<--?--»РезультатыПоиска.Добавить(Результат.Значение); (Проверка: Сервер)
{Отчет.ПоискДанных.Форма.ФормаОтчета.Форма(79,19)}: Переменная не определена (ВыбраннаяСтрока)
ОткрытьЗначение(<--?--»ВыбраннаяСтрока); (Проверка: Тонкий клиент)
Цитировать
 
 
0 #38 nikolaj 23.05.2013 21:11
Alexander, проблема оказалась банальна - опечатка. вместо ИзмеренияОсновн ого я написал ИзмерениеОсновн ого. Плохо что в тексте Запроса нельзя добивать комбинацией Ctrl Пробел...

Еще раз спасибо вам за помощь - без вас бы не справился.
Цитировать
 
 
0 #37 nikolaj 23.05.2013 18:47
Alexander, балин, опять что-то не то, теперь выдаёт ошибку следующую

Ошибка при выполнении обработчика - 'ОбработкаПроведения'
по причине:
{ОбщийМодуль.ПроведениеРасчетов.Модуль(78)}: Ошибка при вызове метода контекста (Выполнить)
ВыборкаРезульта та= Запрос.Выполнить().Выбрать();
по причине:
{(6, 4)}: Не задано значение параметра "ИзмеренияОсновного"
«?»&ИзмеренияОсновного,

У меня вообще отродясь такого параметра не было
Цитировать
 
 
0 #36 nikolaj 23.05.2013 03:47
Александр, ага - это я наплужил вместо поля ЗначениеПериодД ействия с типом число

я выбрал | НачисленияДанны еГрафика.Период Действия КАК Норма с типом Дата
Цитировать
 
 
0 #35 aleksand 21.05.2013 11:36
Nikolay, значит это книжная ошибка, т.к. дату пытаются преобразовать в число
Цитировать
 
 
0 #34 nikolaj 21.05.2013 09:16
Александр, ага, а у Нормы смотрю там тип выражения "Дата"

Я ведь не могу поделить число на дату, так ведь? значит надо поменять тип на число - правильно?
Цитировать
 
 
0 #33 aleksand 21.05.2013 05:57
Николай, ну у тебя ЗаписьРегистра. ИсходныеДанные не является числом, встань отладчиком и посмотри что там, проверь настройки регистра
Цитировать
 
 
0 #32 nikolaj 21.05.2013 04:28
Alexander, Ааааа, потихоньку начинает доходить - я не сделал псевдонимы, Норма - это псевдоним
НачисленияДанны еГрафика.Период Действия КАК Норма
Теперь буду обращать внимание.

Исправил я названия и теперь при попытке провести выдаёт иную ошибку

{ОбщийМодуль.ПроведениеРасчетов.Модуль(42)}: Преобразование значения к типу Число не может быть выполнено
ЗаписьРегистра. Результат=(Запи сьРегистра.Исхо дныеДанные
Цитировать
 
 
0 #31 aleksand 20.05.2013 18:25
Николай, так тебе не нужно ее объявлять, тебе нужно ее получить, "норма" вообще где встречается? в начислениях? наверно ее тоже нужно получать в запросе
Цитировать
 
 
0 #30 nikolaj 20.05.2013 15:08
Alexander, Здравствуйте! Извините за то что в очередной раз вас тираню.
Помогите еще раз чайнику... застрял на 18-м уроке книги Радченко.
При перепроведении документа НачислениеСотру дникам выбрасывает ошибку в общем модуле. Меня как-то сразу насторожило то, что ВыборкаРезульта та.Норма ранее нигде не объявлялось, я объявил Перем Норма; , но ничего не изменилось...
Цитировать
 
 
0 #29 aleksand 20.05.2013 14:15
Ирина, ну пройдитесь отладчиком посмотрите что, где и как передается;
а вообще может у вас процедуры не прописаны в событиях элементов формы
Цитировать
 
 
0 #28 irina 20.05.2013 09:37
Процедура РассчитатьСумму (СтрокаТаблично йЧасти)Экспорт
СтрокаТабличной Части.Сумма=Стр окаТабличнойЧас ти.Количество
*СтрокаТабличнойЧасти.Цена;
КонецПроцедуры

&НаКлиенте
Процедура МатериалыКоличе ствоПриИзменени и(Элемент)
СтрокаТабличной Части=Элементы. Материалы.Текущ иеДанные;
РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
КонецПроцедуры

&НаКлиенте
Процедура МатериалыЦенаПр иИзменении(Элем ент)
СтрокаТабличной Части=Элементы. Материалы.Текущ иеДанные;
РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
КонецПроцедуры
Цитировать
 
 
0 #27 aleksand 19.05.2013 14:19
Ирина, ну так выложите процедуры и укажите как должно быть и что конкретно не работает
Цитировать
 
 
0 #26 irina 19.05.2013 04:38
Добрый вечер. Кому-нибудь приходилось создавать конфигурацию с помощью практического пособия разработчика, версия для обучения (книга 2 диска) ?
Всё ли получилось? У меня процесс остановился на "Одной процедуре для обработки нескольких событий". Все процедуры сто раз перепроверила-н е считает... Я, конечно, нуб полнейший в 1С, но...вдруг дело не во мне)
Цитировать
 
 
0 #25 aleksand 18.05.2013 16:45
Николай, есть разработка "Снегопат" вроде там есть и проверка синтаксиса, в самой платформе как мне кажется ничего подобного нет, но не копался
Цитировать
 
 
0 #24 nikolaj 18.05.2013 16:17
Alexander, подскажите пожалуйста чайнику - в 1С есть что-то вроде Visual Assist, как это имеет место быть в Visual Studio?
Не могу привыкнуть к тому, что синтаксические ошибки не подсвечиваются.
Цитировать
 
 
0 #23 nikolaj 17.05.2013 17:25
Александр, вот я дятел, а! у меня до этого был записан код с тремя запросами, а я его каким то боком удалил(((
Цитировать
 
 
0 #22 aleksand 17.05.2013 05:58
Nikolay, а со своим кодом разбирайтесь откуда все же вы получаете данные т.к. у вас есть и ТекСтрокаМатери алы и ВыборкаДетальны еЗаписи, определитесь откуда берете данные для заполнения движений, если запрос не хотите писать тогда убирайте переменную ВыборкаДетальны еЗаписи и получайте аналогичные данные через цикл по строкам ТЧ
Цитировать
 
 
0 #21 nikolaj 16.05.2013 04:42
Александр, если размещаю в начале, то вообще ппц... аж страшно показывать
Цитировать
 
 
0 #20 aleksand 15.05.2013 12:24
Nikolay, читайте внимательно то что писал я и что говорит 1С - "в начале"(!) это самый верх модуля
Цитировать
 
 
0 #19 nikolaj 14.05.2013 17:44
Александр, после правильно объявления пишет

{Документ.Оказа ниеУслуги.Модул ьОбъекта(10,3)} : Объявления переменных должны быть расположены в начале модуля, процедуры или функции
«?»Перем ВыборкаДетальны еЗаписи; (Проверка: Сервер)
Цитировать
 
 
0 #18 nikolaj 14.05.2013 04:32
Александр, не нужен там Запрос вроде

вот исходник из Документа Приходная Накладная и всё в норме

Процедура ОбработкаПровед ения(Отказ, Режим)
// регистр ОстаткиМатериал ов Приход
Движения.ОстаткиМатериал ов.Записывать = Истина;
Движения.Стоимо стьМатериалов.З аписывать = Истина;
Движения.Управл енческий.Записы вать=Истина;

Для Каждого ТекСтрокаМатери алы Из Материалы Цикл

//регистр ОстаткиМатериал ов Приход
Движение = Движения.ОстаткиМатериал ов.Добавить();
Движение.ВидДви жения = ВидДвиженияНако пления.Приход;
Движение.Период = Дата;
Движение.Матери ал = ТекСтрокаМатери алы.Материал;
Движение.Склад = Склад;
Движение.НаборС войств = ТекСтрокаМатери алы.НаборСвойств;
Движение.Количе ство = ТекСтрокаМатери алы.Количество;

//регистр Стоимость Материалов Приход
Движение = Движения.Стоимо стьМатериалов.Д обавить();
Движение.ВидДви жения = ВидДвиженияНако пления.Приход;
Движение.Период = Дата;
Движение.Матери ал = ТекСтрокаМатери алы.Материал;
Движение.Стоимо сть = ТекСтрокаМатери алы.Сумма;

//регистр Управленческий
Движение=Движен ия.Управленческ ий.Добавить();
// СчетДт - Содержит ссылку на дебетовый счет записи. Только для регистра с поддержкой корреспонденции .
Движение.СчетДт =ПланыСчетов.Ос новной.Товары;
// СчетКт - Содержит ссылку на кредитовый счет записи. Только для регистра с поддержкой корреспонденции .
Движение.СчетКт =ПланыСчетов.Ос новной.РасчетыС Поставщиками;
Движение.Период =Дата;
Движение.Сумма=ТекСтрокаМатери алы.Сумма;
Движение.Количе ствоДт=ТекСтрокаМатери алы.Количество;
//СубконтоДт - Содержит коллекцию значений дополнительных измерений, относящихся к дебетовому счету.
Движение.Субкон тоДт[ПланыВидов Характеристик.В идыСубконто.Мат ериалы]
=ТекСтрокаМатери алы.Материал;

КонецЦикла;

КонецПроцедуры
Цитировать
 
 
0 #17 aleksand 14.05.2013 02:08
Nikolay, объявлена не верно, т.к. переменные в 1С объявляются до основного кода в виде "Перем ВыборкаДетальны еЗаписи;", либо при первом употреблении с заполнением типа и значения, т.е. объявляя в коде ВыборкаДетальны еЗаписи = ""; или ВыборкаДетальны еЗаписи = 0; или ВыборкаДетальны еЗаписи = Ложь и пр.; в данном случае похоже что переменная должна получиться после выполнения запроса и использования метода Выбрать(), так вот вопрос ГДЕ ЗАПРОС К ТЧ?
Цитировать
 
 
0 #16 nikolaj 13.05.2013 20:32
Alexander, я же вроде бы объявил
ВыборкаДетальны еЗаписи;

ну я выше в комментарии разместил исходник
Цитировать
 
 
0 #15 aleksand 12.05.2013 10:15
Николай, ну и где запрос? ВыборкаДетальны еЗаписи - переменная не объявлена и не заполнена
Цитировать
 
 
0 #14 nikolaj 12.05.2013 07:10
Alexander, Здравствуйте! Прошу помощи: не могу доделать 16 урок по книге Радченко - в модуле объекта документа "Оказание Услуги" пишу исходник и мне выдаёт ошибку

{Документ.ОказаниеУслуги.МодульОбъекта(9,25)}: Неопознанный оператор
ВыборкаДетальны еЗаписи«?»; (Проверка: Сервер)
Цитировать
 
 
0 #13 nikolaj 12.05.2013 02:07
вот текст исходника

Процедура ОбработкаПровед ения(Отказ, Режим)

Движения.Остатк иМатериалов.Зап исывать = Истина;
Движения.Стоимо стьМатериалов.З аписывать = Истина;
Движения.Продаж и.Записывать = Истина;
Движения.Управл енческий.Записы вать = Истина;

ВыборкаДетальны еЗаписи;

Если ВыборкаДетальны еЗаписи.ВидНоме нклатуры=Перечи сления.ВидыНоме нклатуры.Матери ал Тогда
// регистр ОстаткиМатериал ов Расход
Движение = Движения.ОстаткиМатериал ов.Добавить();
Движение.ВидДви жения = ВидДвиженияНако пления.Расход;
Движение.Период = Дата;
Движение.Матери ал = ТекСтрокаПерече ньНоменклатуры. Номенклатура;
Движение.Склад = Склад;
Движение.НаборС войств = ТекСтрокаПерече ньНоменклатуры. НаборСвойств;
Движение.Количе ство = ТекСтрокаПерече ньНоменклатуры. Количество;

// регистр СтоимостьМатери алов Расход
Движение = Движения.СтоимостьМатери алов.Добавить();
Движение.ВидДви жения = ВидДвиженияНако пления.Расход;
Движение.Период = Дата;
Движение.Матери ал = ТекСтрокаПерече ньНоменклатуры. Номенклатура;
Движение.Стоимо сть = Стоимость;

//Регистр Управленческий
// Первая проводка: Д 62(ДебиторскаяЗ адолженность)- К 90(Капитал) Розничная Сумма
Движение=Движен ия.Управленческ ий.Добавить();
Движение.СчетДт =ПланыСчетов.Ос новной.Дебиторс каяЗадолженност ь;
Движение.СчетКт =ПланыСчетов.Ос новной.Капитал;
Движение.Период =Дата;
Движение.Сумма= ВыборкаДетальны еЗаписи.СуммаВД окументе;
Движение.Субкон тоДт[ПланыВидов Характеристик.В идыСубконто.Кли енты]=Клиент;

//Вторая проводка: Д 90(Капитал) - К 41(Товары)-себе стоимость
Движение=Движен ия.Управленческ ий.Добавить();
// СчетДт - Содержит ссылку на дебетовый счет записи. Только для регистра с поддержкой корреспонденции .
Движение.СчетДт =ПланыСчетов.Ос новной.Капитал;
// СчетКт - Содержит ссылку на кредитовый счет записи. Только для регистра с поддержкой корреспонденции .
Движение.СчетКт =ПланыСчетов.Ос новной.Товары;
Движение.Период =Дата;
Движение.Сумма= СтоимостьМатери ала*ВыборкаДета льныеЗаписи
.КоличествоВДок ументе;
Движение.Количе ствоКт=ВыборкаДетальныеЗаписи.КоличествоВДок ументе;
Движение.Субкон тоКт[ПланыВидов Характеристик.В идыСубконто.Мат ериалы]
=ВыборкаДетальн ыеЗаписи.Номенк латура;
КонецЕсли;


// КонецЦикла;
КонецПроцедуры
Цитировать
 
 
0 #12 nikolaj 11.05.2013 08:15
Прошу помощи: не могу доделать 16 урок по книге Радченко - в модуле объекта документа "Оказание Услуги" пишу исходник и мне выдаёт ошибку

{Документ.ОказаниеУслуги.МодульОбъекта(9,25)}: Неопознанный оператор
ВыборкаДетальны еЗаписи«?»; (Проверка: Сервер)
Цитировать
 
 
0 #11 nikolaj 10.05.2013 14:07
Vyacheslav, Здравствуйте, я тоже на 13 уроке встрял((

при формировании отчета "Рейтинг услуг" выдаёт такую вот таблицу непонятную.
Цитировать
 
 
0 #10 vjachesl 09.05.2013 20:25
когда делаю ограничение прав на просмотр, при условии что в документе есть премия(ее нельзя просматривать) пишет:

{(6.43)}: Поле не найдено "Документ.НачисленияСотру дникам.Начисления.ВидРасчета"
Документ.НачисленияСотру дникам.Начисления.
<>ВидРасчета=Значение(ПланВидовРасчета.ОсновныеНачисления.Премия)

вот ограничение в документе НачисленияСотру дникам для "Прочия поля" :

ДокНачисления ГДЕ Не 1 в (#ЕстьПремия("ДокНачисления"))

В Шаблонах ограничения написал:

Выбрать
1
из
Документ.НачисленияСотру дникам.Начисления
Где
Документ.НачисленияСотру дникам.Начисления.ВидРасчета=Значение(ПланВидовРАсчета.ОсновныеНачисления.Премия)
И Документ.НачисленияСотру дникам.Начисления.Ссылка=#Параметр(1).Ссылка
Цитировать
 
 
0 #9 vjachesl 09.05.2013 04:19
Значит все так галочка не нужна в моем случае, т.к. я обращаюсь к имени верно? Получается в Радченко опечатка?
Цитировать
 
 
0 #8 aleksand 08.05.2013 14:35
Вячеслав, в общем модуле ПроведениеРасче тов во втором запросе пропущена запятая (Условие идет 4-м параметром, а не 3-им):
|РегистрРасчета.Начисления.БазаНачисления(&ИзмеренияОсновного,
|&ИзмеренияБазового, , Регистратор=&Ре гистратор И ВидРасчета=&Вид Расчета И
|Сотрудник В(&СписокСотруд ников)) КАК НачисленияБазаНачисления";

По простому - если ставишь галочку Глобальный то все процедуры и функции этого модуля находятся в Глобальном контексте и обращаться к ним нужно напрямую: РассчитатьНачисления;
если общий модуль неглобальный, то к процедуре обращаемся через имя модуля: ПроведениеРасче тов.РассчитатьНачисления
Цитировать
 
 
0 #7 vjachesl 07.05.2013 18:09
при перепроведении документа Начисление сотрудникам #1 в 1с:предприятие выдается ошибка:
(свойство глобальный у общего модуля ПроведениеРасче тов выключено)

Ошибка при выполнении обработчика - 'ОбработкаПроведения'
по причине:
{ОбщийМодуль.ПроведениеРасче тов.Модуль(66)}: Ошибка при вызове метода контекста (Выполнить)
ВыборкаРезультата=Запрос.Выполнить().Выбрать();
по причине:
{(6, 71)}: Неверные параметры "РегистрРасчета .Начисления.Баз аНачисления, 2"
&ИзмеренияБазового, Регистратор=&Ре гистратор И ВидРасчета=&Вид Расчета <

В книге написано, у общего модуля ПроведениеРасче тов необходимо указать свойство глобальный(Гало чка глобальный), на картинке ее нету, соответственно я запутался, нужна ли она, т.к. при включении этого свойства документ НачисленияСотру дникам Выдает ошибку

{Документ.НачисленияСотру дникам.МодульОбъекта(43,2)}: Переменная не определена (ПроведениеРасче тов)
<>ПроведениеРасче тов.РассчитатьНачисления(Движения.Начисления, ПланыВидовРасче та.ОсновныеНачи сления.Оклад, МассивСотрудников);
{Документ.НачисленияСотру дникам.МодульОбъекта(46,2)}: Переменная не определена (ПроведениеРасче тов)
<>ПроведениеРасче тов.РассчитатьНачисления(Движения.Начисления, ПланыВидовРасче та.ОсновныеНачи сления.Премия, МассивСотрудников);

Что значит это свойство глобальный у общего модуля, зачем оно? Как исправить ошибки?
Цитировать
 
 
0 #6 aleksand 07.05.2013 16:37
Вячеслав, |ОказаниеУслуги ПереченьНоменкл атуры.Номенклат ура.ВидНоменкла туры"; - рано закрываешь текст запроса нужна "," вместо ";

Запрос.Установи тьПараметр("Ссы лка", Ссылка) ";" - потерял
Цитировать
 
 
0 #5 vjachesl 06.05.2013 09:27
модуль выдает ошибку:
{Документ.ОказаниеУслуги.МодульОбъекта(148,13)}: Обнаружено логическое завершение исходного текста модуля
КонецЕсли;<> (Проверка: Сервер)
Помогите устранить пожалуйста. Текст прикрепил
Цитировать
 
 
0 #4 vjachesl 06.05.2013 05:20
Александр, Спасибо, вроде исправил, ошибка была в модуле документа Оказание услуг, в движении по регистру продаж. Сейчас вроде стал считать!
Цитировать
 
 
0 #3 aleksand 05.05.2013 14:16
Вячеслав, открой РегистрНакоплен ия.Продажи и посмотри есть ли движения и заполнена ли Выручка
Цитировать
 
 
0 #2 vjachesl 04.05.2013 19:05
ВЫБРАТЬ
спрНоменклатура .Ссылка КАК Услуга,
ПродажиОбороты. ВыручкаОборот КАК Выручка
ИЗ
Справочник.Номе нклатура КАК спрНоменклатура
ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакоплен ия.Продажи.Обор оты КАК ПродажиОбороты
ПО ПродажиОбороты. Номенклатура = спрНоменклатура .Ссылка
ГДЕ
спрНоменклатура .ЭтоГруппа = ЛОЖЬ
И ПродажиОбороты. Номенклатура.ВидНоменклатуры = &ВидНоменклатуры

УПОРЯДОЧИТЬ ПО
Выручка УБЫВ
Цитировать
 
 
0 #1 aleksand 04.05.2013 05:35
Вячеслав, Код запроса в студию, экстрасенсы в отпуске... Документы проведены точно в данном интервале дат?
Цитировать
 

Добавить комментарий


Защитный код
Обновить