Как с помощью формул сделать другой формат

Категория Помощь

Добрый день, Эдуард!Подскажите, пожалуйста, есть ли в Excel формулы, для преобразования одного формата в другой формат. Формула РУБЛЬ (DOLLAR) приписывает к числу "р" (в зависимости от языковых настроек). А есть ли формулы, которые бы приписывали знак евро, юань и др. Я понимаю, что можно сделать руками через вкладку Главная - Формат ячеек. А как с помощью формул? Или только макросом, это можно сделать?Спасибо! Добрый день, Эдуард!
Подскажите, пожалуйста, есть ли в Excel формулы, для преобразования одного формата в другой формат. Формула РУБЛЬ (DOLLAR) приписывает к числу "р" (в зависимости от языковых настроек). А есть ли формулы, которые бы приписывали знак евро, юань и др. Я понимаю, что можно сделать руками через вкладку Главная - Формат ячеек. А как с помощью формул? Или только макросом, это можно сделать?
Спасибо!

Комментарии  

 
0 #5 eduard 17.05.2013 23:13
Anna, а зачем тогда формула. Может быть просто достаточно настроить формат?
Цитировать
 
 
0 #4 viktorij 16.05.2013 02:27
Anna, разъясните суть такой задачи. Хорошо бы с примером. "Что есть" - "что хочу".
Цитировать
 
 
0 #3 anna 12.05.2013 00:30
Спасибо! Извините, но я не уточнила, про ТЕКСТ знаю, но тогда число становится текстом. А ТЕКСТ делает именно текстовый формат, а не числовой. А есть формула, чтобы она число оставляло число, но со знаком $, юань.
Цитировать
 
 
0 #2 viktorij 06.05.2013 09:52
Для евро:
=ТЕКСТ(A1;"[$€-2] # ##0,00")
или
=ТЕКСТ(A1;"# ##0,00\ [$€-1]")
А вот какой знак у юаня?! (Далеко Питер от Китая... ) 8-))
Цитировать
 
 
0 #1 eduard 03.05.2013 02:40
Да, такая формула есть. Она называется TEXT. Например, у вас есть дата 31.12.2011 в ячейке A1. Формула =TEXT(A1;"ДД ММММ ГГГГ") вернет Вам в текстовом формате "31 Декабря 2011".
Цитировать
 

Добавить комментарий


Защитный код
Обновить