Помогите написать формулу для облегчения работы

Категория Помощь

Доброго всем дня. Вопрос в следующем.К примеру есть значение в ячейке С1 и диапазон значений А1:В100. Хочу реализовать следующую функцию: Если значение С1 присутствует в диапазоне А1:В100, то оно выделяется зеленым, если нет - красным. Можно просто 1-0. Буду благодарен за помощь. Доброго всем дня. Вопрос в следующем.

К примеру есть значение в ячейке С1 и диапазон значений А1:В100. Хочу реализовать следующую функцию: Если значение С1 присутствует в диапазоне А1:В100, то оно выделяется зеленым, если нет - красным. Можно просто 1-0. Буду благодарен за помощь.

Комментарии  

 
0 #12 evgenij 17.06.2013 03:53
Здравствуйте, маленький вопросик - выражение sin(tg(6.7)) в формулу =SIN(TAN(6.7))^ 2 я правильно записал?
Цитировать
 
 
0 #11 elena 15.06.2013 04:29
Спасибо, Виктория, то что нужно...!!!!!!! !!!! Огромное спасибо! Поработаю с такой функцией, чтобы разобраться окончательно!
Цитировать
 
 
0 #10 viktorij 12.06.2013 06:29
Елена, прикрепила файл. По-моему, верный вариант таблицы - 1-й.
Поменяйте значения в зелёной ячейке (D20), проверьте. (Подразумеваетс я, что показатель - неотрицательное число, т.е. >=0)
Цитировать
 
 
0 #9 viktorij 05.06.2013 14:52
Елена, совет - поможет также функция ГПР(), менее громоздкая формула будет, чем с ЕСЛИ() . Только с начальным и последними значениями не совсем понятно - почему в табличке 5 в первой строке, а интервал - от 0 до 9, и ещё "странное"- пометила в файле.
Цитировать
 
 
0 #8 eduard 01.06.2013 09:22
Елена, в этом случае нужна именно функция ЕСЛИ. В ней можно задавать не только конкретные числа, но и ссылки на ячейки, например, =ЕСЛИ(А1>B2;ЕСЛИ(A1Ссылки здесь "от фонаря". Но логика понятна.
Цитировать
 
 
0 #7 elena 13.05.2013 11:08
Второй день бьюсь с формулой, если бы там были конкретные цифры, от которых зависит значение, то получилось бы, несколько таких формул я забила, но тут согласно таблицы, пределы числ, в этом вся и загвоздка, может быть есть другая функция не "если". Один бы раз разобраться, и пошло бы дальше как по маслу.
Цитировать
 
 
0 #6 eduard 13.05.2013 01:14
Елена, подробное описание функции ЕСЛИ - здесь. http://youcanexcel.ru/index.php/temp-articles/83-if
Если что-то конкретное не получится, пишите.
Цитировать
 
 
0 #5 vasilij 12.05.2013 14:43
Чем больше нового узнаёшь об Excel, тем больше понимаешь насколько "универсальный" этот инструмент:)
Цитировать
 
 
0 #4 vasilij 09.05.2013 06:35
Алексей, см.ответ Виктории. Знак "$" - фиксирует диапазон либо по строкам D$3, либо по столбцам $D3, либо и то и другое вместе $D$3. В вашем случае нужно строку освободить - $D3
Цитировать
 
 
0 #3 viktorij 07.05.2013 12:32
Алексей, а Вы удалите в вашей формуле символы $ в ссылке на ячейку D3, а потом уже копируйте вниз.
Цитировать
 
 
0 #2 aleksej 06.05.2013 18:51
Василий, по файлику Книга1. А если значение, которое нужно найти не одно, а их несколько. Можно ли применить правило к диапозону, столбцу? Попробовал продлить ниже D3 формулу, он ставит ее как =СЧЁТЕСЛИ($A$3: $B$12;$D$3)=0 (не меняет на $D$4)
Цитировать
 
 
+2 #1 vasilij 03.05.2013 00:21
Условное форматирование - > Создать правило -> Использовать формулу для определения форматируемых ячеек
Правило (формула):
=СЧЁТЕСЛИ($A$1:$B$100;$C$1)=0 (красный цвет, т.е. отсутствует)
=СЧЁТЕСЛИ($A$1:$B$100;$C$1)>0 (зелёный цвет, т.е. присутствует)
Применяется к: $C$1
Цитировать
 

Добавить комментарий


Защитный код
Обновить